summaryrefslogtreecommitdiff
path: root/dev-python/munch/munch-2.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/munch/munch-2.3.2.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/munch/munch-2.3.2.ebuild')
-rw-r--r--dev-python/munch/munch-2.3.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/munch/munch-2.3.2.ebuild b/dev-python/munch/munch-2.3.2.ebuild
new file mode 100644
index 000000000000..b3800a6f6eea
--- /dev/null
+++ b/dev-python/munch/munch-2.3.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A dot-accessible dictionary (a la JavaScript objects)"
+HOMEPAGE="https://github.com/Infinidat/munch"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"