summaryrefslogtreecommitdiff
path: root/dev-python/mss/mss-7.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-28 09:59:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-28 09:59:10 +0100
commit8eb973cc2247ee4fe34e4d907fdc6cf5b94709e3 (patch)
tree0834df6dbfa798c2c138698cc26cf6a731fe937e /dev-python/mss/mss-7.0.1.ebuild
parente5985b8e66b3b43c34328efb47b9b12e8ce5a690 (diff)
gentoo auto-resync : 28:10:2022 - 09:59:10
Diffstat (limited to 'dev-python/mss/mss-7.0.1.ebuild')
-rw-r--r--dev-python/mss/mss-7.0.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/mss/mss-7.0.1.ebuild b/dev-python/mss/mss-7.0.1.ebuild
new file mode 100644
index 000000000000..7757ba909e7a
--- /dev/null
+++ b/dev-python/mss/mss-7.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 virtualx
+
+MY_P=python-${P}
+DESCRIPTION="An ultra fast cross-platform multiple screenshots module in python using ctypes"
+HOMEPAGE="
+ https://github.com/BoboTiG/python-mss/
+ https://pypi.org/project/mss/
+"
+SRC_URI="
+ https://github.com/BoboTiG/python-mss/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ sys-process/lsof
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # upstream tests for self-build, apparently broken by setuptools
+ # issuing deprecation warnings
+ mss/tests/test_setup.py
+)
+
+src_test() {
+ virtx distutils-r1_src_test
+}