summaryrefslogtreecommitdiff
path: root/dev-python/mpi4py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-python/mpi4py
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-python/mpi4py')
-rw-r--r--dev-python/mpi4py/Manifest2
-rw-r--r--dev-python/mpi4py/mpi4py-3.0.2.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/mpi4py/Manifest b/dev-python/mpi4py/Manifest
index 4aca40cf0c07..b488031e874d 100644
--- a/dev-python/mpi4py/Manifest
+++ b/dev-python/mpi4py/Manifest
@@ -1,5 +1,7 @@
DIST mpi4py-2.0.0.tar.gz 1279957 BLAKE2B ad75492ec09edbf6663a8962bcb4592c076ef47cdf8a9c14275077dea0abf4ce01f928d03eec80941fec37941c2ba99287263b71436baf7ed755a84cca2ea983 SHA512 6459b482db782fea1a80499774ebfeb09c828b6c3f1805a0ca306f26f3ebcac52ad1c83bb97a98a01b518b6a6c887f6b99dbda9c37381a5ce05ddff0edb16d81
DIST mpi4py-3.0.0.tar.gz 1426843 BLAKE2B a68182c6abebac6af73654f04db9eba38f020793a9f6d0f98a5e4a483b0531e44aca3c853c20572123cc02331350bf98f8405ddd12b77e79de732f714437da9f SHA512 29ce8b7fd187aadd0bf8e1928ed00cac3e898ff82432b7a95984a248559b0d580c5af418b1986d83b17ad2cf8cbb45135afacf290ba4d9b75a62b03e9ca08e16
+DIST mpi4py-3.0.2.tar.gz 1429331 BLAKE2B 9e35749a82698ec656553583f01ebd8edbfb3b649c7693a9ff63f9f6abfa3fd41a54cbe4e3a1de55cbaf4dc626602706c776c505d0f5c0d82ebe88f2b4ceeddb SHA512 0a18332fd45e8e80b8dab0761fbaa30444a0d55776af7a2333be17ade827e92d04ac5bb8619ce26937142f344f75de0e5ef6dcb7502f33389716aa9482ddf5ab
EBUILD mpi4py-2.0.0.ebuild 1114 BLAKE2B e8ba3c2d390b3cb89f4d6a265a14e1a37db4d64de254dc6e0226c12339ded13ae217b03f202bb4f673b73c8225ce4a02aeaffa0bc15acdc2ed19a28a4d911e9a SHA512 2660ff53f787c9ce1dbae757c79328d53062ec317a8d4e72435fc1f8887cbec601f054a879be7465e95f2e385977630289a0bb48f550cc15b9df2e219fcd2aa1
EBUILD mpi4py-3.0.0.ebuild 1116 BLAKE2B d6023428513b82e92623455a695cf07cacc524ba73ef7d2d4690f87f7da2a630e340993a54961ab12d6812dda09c3ecff3ef92cd846fc75dec8e288c2b33f697 SHA512 cb974499fdb92c7b1b701811bc7c75ed691c7e97e777f4de68c2e1e6546a9ffbfa0271ffa6218becd870597140ac6f1d39b615d7e0d1b0b852e12c3dac0344a0
+EBUILD mpi4py-3.0.2.ebuild 1124 BLAKE2B 011352a5f4293c584337fa2712bdd90f3719a2566833d33a25fc11c417276e990c38cb2b3a8568940812da5c659a238fd426a6d6f569be9adc3299d5e352c260 SHA512 b120ac44398a081b6e6f6de54ab5931e1c02a028736628ab9e4f68abd58a4cd9c84a9aa35c9c9fb2eb9fd9a4b4ad79a3a0c4a15fd549bfd2e0fc097322e16fad
MISC metadata.xml 1118 BLAKE2B 0bc626a2106e628d7eb639e6ce90c4badb63ec2ea66b0322e7b83418791b7edc4bd443294fba3d31133812416eb4428b5dc47d074da3aeebf6867e8a0998d046 SHA512 7afb6d05007036bf5562d6d262165d8c2576bb49a86f9230f939d6a2ef929affa8461fa6421ffd8d97203a4425b397a8dd8556190364f29622e53a67674978c7
diff --git a/dev-python/mpi4py/mpi4py-3.0.2.ebuild b/dev-python/mpi4py/mpi4py-3.0.2.ebuild
new file mode 100644
index 000000000000..a9ab0f634606
--- /dev/null
+++ b/dev-python/mpi4py/mpi4py-3.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Message Passing Interface for Python"
+HOMEPAGE="https://bitbucket.org/mpi4py/ https://pypi.org/project/mpi4py/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="virtual/mpi"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ virtual/mpi[romio]
+ )
+"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # not needed on install
+ rm -vr docs/source || die
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ export FAKEROOTKEY=1
+ distutils-r1_src_compile
+}
+
+python_test() {
+ echo "Beginning test phase"
+ pushd "${BUILD_DIR}"/../ &> /dev/null || die
+ mpiexec -n 2 "${PYTHON}" ./test/runtests.py -v || die "Testsuite failed under ${EPYTHON}"
+ popd &> /dev/null || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ use examples && local DOCS=( demo )
+ distutils-r1_python_install_all
+}