summaryrefslogtreecommitdiff
path: root/dev-python/moto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 07:53:35 +0000
commite393c0503a79342594a61547dc43f80f8bcc086e (patch)
tree3254e8166c98b932add34913169c98f7b7f9fa5f /dev-python/moto
parentb46782805d0eed36ce9685f7e9abf25671f24d7d (diff)
gentoo auto-resync : 21:12:2022 - 07:53:34
Diffstat (limited to 'dev-python/moto')
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-4.0.12-r1.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 196bfb677818..5b5317f93943 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -5,6 +5,7 @@ DIST moto-4.0.8.tar.gz 2488253 BLAKE2B ae707de8f0917b62904f38f977eded8f3e995271d
DIST moto-4.0.9.tar.gz 2496530 BLAKE2B 596dc00ce0c931d4405d1ad6fdfcff4acc5c7421b1f1d67f442e090249d3df81f89c570368b5e981ec49f14a35aed32621ff3dbedc7003e3c870f891e4eda20a SHA512 fedf2c97779a93b1ab3492122be5425f3d91219eb207cc21bf2822ffa52c6efe2c3c8ca233acafd02c725c46e77e883f8f941c29638bb3e32ffa774ed8a5ff69
EBUILD moto-4.0.10.ebuild 4129 BLAKE2B 5835bbdaff08816eafec87a9a9de840ef6d9b9e4cc8c295a34a1116156be932dd70bd89f1d3ebf34051ac223a88aaca8cf18c957c36ec774c8d1538e71af1b7d SHA512 e5e5c86c34384342934029b91fa682fc4cd56fbb521cb1f4fc5508188a2f574ce2f0e93a0b5abf72ce864bc1decd896e474d69b7882612a9ef0c37fa4537992a
EBUILD moto-4.0.11.ebuild 4131 BLAKE2B f02a5b9be9428526b3d98a1fd1d56d30a38f349d68f3a802b40fb99d49206393ca4e90d2c8b26e46ab848f888361d75e80fef457e94e74bdd971c3c757e57285 SHA512 ac877bbc209501ab4e32a98b79d9d03e1a64c7ee7485b700b0e3cbdb63b16cd95109eae930a5685d99c27c84af24479b15d882999a57a2bab34798142d786811
+EBUILD moto-4.0.12-r1.ebuild 4097 BLAKE2B 6653cce5ff5baab77c2b547112f1ff94b61650b1c903b923b38ae13020c4804e4685741a9c300871c6628d3e214dca071f17cbb8948834c46c5f2cb06c279b52 SHA512 ef580ef5348017916e843043c6faf39b8214215ae7ce03b3b442f02fc53c9df4b17fc0f2201e6961fd865ddea9faa25dafb2500d07dfb5c1ec657d1da45a256c
EBUILD moto-4.0.12.ebuild 4096 BLAKE2B 718b2628412e536bfb477e24f4fcae145c55897b42cc9be3ade397913f53ae637efd2649d11248dc65ed8e3186864d0cbfe98ad444e7feafa59b160c70ff4d26 SHA512 325f444ae9be5ca37186898719e1ef3cef1d0641710c736cc6133d7864fa6984f792747f7e39e9b892b82448f7e5278c3be29b411a2c1a5525ae434b16e866eb
EBUILD moto-4.0.8.ebuild 4168 BLAKE2B f7b93227ed08d35d0576af80b74ddce6287abde1a8a53188e6d78a0e39950f8ff43f1597f621da68046d93eae09b53a16511411aba98988ea9062f9cbfe29295 SHA512 954133862dd6ce7ae667104e0650ec2696104a494c0d07772a58456d4c61844d63d6215dd613aa49a74c3b3eaa270e1736b12880799a531ca0ac0f7d9bba4851
EBUILD moto-4.0.9.ebuild 4170 BLAKE2B 40f9e16c72e4d0e9f85f77a638010028bf8037ac5b35d936860a02b12975088991bfbe46a5ced21416001765594669e688c8d43fe5a1c1c146d2b34b82b8e774 SHA512 0e4a3523bd9c58bf304b847a31b637f53de466850e921513ca70eb2772fa26abf1132db4ff5b88c7fc557c9947dda3e54cb2d5d58a9d96678ec5860809641bc8
diff --git a/dev-python/moto/moto-4.0.12-r1.ebuild b/dev-python/moto/moto-4.0.12-r1.ebuild
new file mode 100644
index 000000000000..605ecb800e01
--- /dev/null
+++ b/dev-python/moto/moto-4.0.12-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="
+ https://github.com/spulec/moto/
+ https://pypi.org/project/moto/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ >=dev-python/cfn-lint-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ tests/test_appsync/test_server.py::test_appsync_list_tags_for_resource
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_s3/test_server.py::test_s3_server_post_to_bucket_redirect
+ tests/test_s3/test_multiple_accounts_server.py::TestAccountIdResolution::test_with_custom_request_header
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network'
+}