summaryrefslogtreecommitdiff
path: root/dev-python/mongomock/mongomock-3.22.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/mongomock/mongomock-3.22.1.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/mongomock/mongomock-3.22.1.ebuild')
-rw-r--r--dev-python/mongomock/mongomock-3.22.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/mongomock/mongomock-3.22.1.ebuild b/dev-python/mongomock/mongomock-3.22.1.ebuild
new file mode 100644
index 000000000000..5195c13b7f1a
--- /dev/null
+++ b/dev-python/mongomock/mongomock-3.22.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to help testing Python code that interacts with MongoDB via Pymongo"
+HOMEPAGE="https://github.com/mongomock/mongomock https://pypi.org/project/mongomock/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND=">=dev-python/pbr-5.1.1[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ >=dev-python/pymongo-3.10.1[${PYTHON_USEDEP}]
+ >=dev-python/sentinels-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.14.0[${PYTHON_USEDEP}]"
+
+src_test() {
+ # Use NO_LOCAL_MONGO to disable tests that need a MongoDB instance.
+ # TZ=UTC needed for date/time tests to pass
+ TZ=UTC NO_LOCAL_MONGO=1 distutils-r1_src_test
+}
+
+distutils_enable_tests pytest