summaryrefslogtreecommitdiff
path: root/dev-python/moddb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 14:51:38 +0000
commitd414c993cafd9e31a370c4a5aae042c710df2419 (patch)
treea4e123f32e84e3c7c7fdde2f083b1831f018bef6 /dev-python/moddb
parent21dbcce41990b13f301240313be05c8d013a9258 (diff)
gentoo auto-resync : 28:01:2023 - 14:51:38
Diffstat (limited to 'dev-python/moddb')
-rw-r--r--dev-python/moddb/Manifest3
-rw-r--r--dev-python/moddb/metadata.xml13
-rw-r--r--dev-python/moddb/moddb-0.8.1.ebuild54
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-python/moddb/Manifest b/dev-python/moddb/Manifest
new file mode 100644
index 000000000000..196ef28e0690
--- /dev/null
+++ b/dev-python/moddb/Manifest
@@ -0,0 +1,3 @@
+DIST moddb-0.8.1.gh.tar.gz 68417 BLAKE2B e013c6a2c315eb3f36ace6f37eadacd50a5854726cb6cbcbc6d16170bc1af06bf973d9874909ecb6e70c5a3cb896ef559eb6e915eed41217069fc3c7f468e57e SHA512 3557881f9bc33c911ba2e3d845a8294116c5ea394de4f24ab05a0d0af07ae000e972db9077fad8a1a30941a66b7f560cfce0616df93f1bae835efb51ee6035e2
+EBUILD moddb-0.8.1.ebuild 1453 BLAKE2B f3381fd4ca75b93cb13b6a7dc9123c8ef20531b4e744b87c2613af8b5d0a822de8a09c0fcc4cb4c006216cdea5a80115015f464b0cf63eac12ec543ad2037ac1 SHA512 8f00473c104ab7c5eb03e8b4477758435051ba63f88e87494f26f5ce873e9d3b705c5a88d9ea69b966d4d9c459e1ebd05d92f3b621d3bbd2f2ab62753d9beb34
+MISC metadata.xml 407 BLAKE2B c1651872c2ae76f7adf6fd307c7b7b3c4ff5c9b7a193d58651648de31c63f9c24e35c178ac4fbed18c2bdd247cf2fd247e1a579a1dea92747f5545f155ef5595 SHA512 e24bb351e9a98d5c86694447a9c4007df28de831f4a570e998316d81688347f038cd802441f89ab9cdcc7b4ab7079096ca3c8ff590ac7bf5453e442186304d5d
diff --git a/dev-python/moddb/metadata.xml b/dev-python/moddb/metadata.xml
new file mode 100644
index 000000000000..7fdd458f8299
--- /dev/null
+++ b/dev-python/moddb/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">moddb</remote-id>
+ <remote-id type="github">ClementJ18/moddb</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/moddb/moddb-0.8.1.ebuild b/dev-python/moddb/moddb-0.8.1.ebuild
new file mode 100644
index 000000000000..4d37fb8e9f73
--- /dev/null
+++ b/dev-python/moddb/moddb-0.8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scrapper to access ModDB mods, games and more as objects"
+HOMEPAGE="https://github.com/ClementJ18/moddb"
+SRC_URI="https://github.com/ClementJ18/moddb/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Connects to moddb.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ dev-python/pyrate-limiter[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+)"
+
+EPYTEST_DESELECT=(
+ # These tests require valid moddb.com login information
+ "tests/test_base.py::TestLogin::test_login"
+ "tests/test_client.py::TestClient::test_get_watched"
+ "tests/test_client.py::TestClient::test_get_updates"
+ "tests/test_client.py::TestClient::test_posts"
+ "tests/test_client.py::TestClient::test_friends"
+ "tests/test_client.py::TestClient::test_messages"
+)
+
+distutils_enable_sphinx docs/source dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest
+
+python_test() {
+ # Dummy moddb.com login information
+ export USERNAME="portage"
+ export SENDER_USERNAME="portage"
+ export PASSWORD="testing"
+ export SENDER_PASSWORD="testing"
+ epytest
+}