summaryrefslogtreecommitdiff
path: root/dev-python/mock/mock-1.0.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/mock/mock-1.0.1-r2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/mock/mock-1.0.1-r2.ebuild')
-rw-r--r--dev-python/mock/mock-1.0.1-r2.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/mock/mock-1.0.1-r2.ebuild b/dev-python/mock/mock-1.0.1-r2.ebuild
deleted file mode 100644
index 891538afdf95..000000000000
--- a/dev-python/mock/mock-1.0.1-r2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python Mocking and Patching Library for Testing"
-HOMEPAGE="http://www.voidspace.org.uk/python/mock/ https://pypi.org/project/mock/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc test"
-
-# dev-python/unittest2 is not required with Python >=3.2.
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' python2_7 pypy)
- )"
-RDEPEND=""
-
-PATCHES=( "${FILESDIR}"/${P}-fix-python3.4.patch )
-
-python_test() {
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( docs/*.txt )
-
- distutils-r1_python_install_all
-
- if use doc; then
- dohtml -r html/ -x html/objects.inv -x html/output.txt -x html/_sources
- fi
-}