summaryrefslogtreecommitdiff
path: root/dev-python/mmtf-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-python/mmtf-python
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-python/mmtf-python')
-rw-r--r--dev-python/mmtf-python/Manifest2
-rw-r--r--dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild19
2 files changed, 14 insertions, 7 deletions
diff --git a/dev-python/mmtf-python/Manifest b/dev-python/mmtf-python/Manifest
index 65d6aa4861c0..890f3cb79012 100644
--- a/dev-python/mmtf-python/Manifest
+++ b/dev-python/mmtf-python/Manifest
@@ -1,3 +1,3 @@
DIST mmtf-python-1.1.2.tar.gz 46309 BLAKE2B b21d53f7cfbdf6f6bd4f0f3ac31a846e83ce0ee98faf77fa8d06de7520c4aa64a259e8b43a744a440a6cf1a10ad461697334683364698a68222b690301bc5554 SHA512 92afcce48c2de186cbf9c2cb39c94c5df14ae0eb613862d41b674b7d2f338855ed81be23fb14d16d2dfc8d33415d3904537ef4a422e3a52b78d461b609e968ca
-EBUILD mmtf-python-1.1.2-r1.ebuild 465 BLAKE2B 8fe3446a21d333f5a3d9a1a352327a83a1158b7dd821826d9370851319ca4c62de4be868f82f02fec4edb13a529d8177140d91eebc4d32989a4b45a17ad7fe53 SHA512 5c647cfb736e58cf1cac991b4d11ab31d10b2141110abef40fc31184dc350769b7f3a1287ba320aca7caddd7427d64b3bc53597d7eeb39afb19d38dc25f70031
+EBUILD mmtf-python-1.1.2-r1.ebuild 645 BLAKE2B d27592548b28d84bc84fd529ef685c817dc7e93ec09b621747cb022a41fc9530ce969b17880627e8e08e2dcc86bfc14b8eba72a63ce9060907e885cc3b14a027 SHA512 17f96f4537e13a53395b97be0270ab8388d0901da8d45daa83e61577c521cb0e698580f5be1fd917a926aa01a5bda71f45619a053ee0fdeaffa038fb9b2b8c01
MISC metadata.xml 378 BLAKE2B d981d836e572089d938cf57410fe21d8e8b84c29edf9808f640f8e51833b61bca99b697e17422fbd4073ce19f0269fe6c501f9fbd3e48fbb909f8c81cc6ec66c SHA512 8a75b7e5639b96c103e6ea40e858029826fe0aa9ce95050f5217f6545751516247b246d1f0c7b7818fd31bae0d4e0578515cd99d939ccb2c09543bdb034c69ca
diff --git a/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild b/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild
index 30c4a5814f61..fd6c4965d1ce 100644
--- a/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild
+++ b/dev-python/mmtf-python/mmtf-python-1.1.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="The python implementation of the MMTF API, decoder and encoder"
@@ -13,9 +13,16 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="dev-python/msgpack[${PYTHON_USEDEP}]"
BDEPEND="
- dev-python/msgpack[${PYTHON_USEDEP}]"
-RDEPEND="
- ${BDEPEND}"
+ test? (
+ ${RDEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" mmtf/tests/codec_tests.py -v || die "Tests failed with ${EPYTHON}"
+}