summaryrefslogtreecommitdiff
path: root/dev-python/ml-dtypes/ml-dtypes-0.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-22 23:59:31 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-22 23:59:31 +0100
commit1f00990debeffd0052c194989d0a02baac23eb96 (patch)
treeecc3dfafe935354404f7a0689a6ad809ebaba580 /dev-python/ml-dtypes/ml-dtypes-0.3.2.ebuild
parent02eb6576978c38afed5787f6f2dbab8353379d66 (diff)
gentoo auto-resync : 22:04:2024 - 23:59:31
Diffstat (limited to 'dev-python/ml-dtypes/ml-dtypes-0.3.2.ebuild')
-rw-r--r--dev-python/ml-dtypes/ml-dtypes-0.3.2.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/ml-dtypes/ml-dtypes-0.3.2.ebuild b/dev-python/ml-dtypes/ml-dtypes-0.3.2.ebuild
deleted file mode 100644
index e12495719202..000000000000
--- a/dev-python/ml-dtypes/ml-dtypes-0.3.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PNGH="${PN/-/_}" # pypi is ml-dtypes, github is ml_dtypes
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-EIGEN_CommitId="7bf2968fed5f246c0589e1111004cb420fcd7c71"
-
-DESCRIPTION="A stand-alone implementation of several NumPy dtype extensions"
-HOMEPAGE="https://github.com/jax-ml/ml_dtypes"
-SRC_URI="
- https://github.com/jax-ml/${PNGH}/archive/refs/tags/v${PV}.tar.gz -> ${PNGH}-${PV}.gh.tar.gz
- https://gitlab.com/libeigen/eigen/-/archive/${EIGEN_CommitId}/eigen-${EIGEN_CommitId}.tar.bz2
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-S="${WORKDIR}/${PNGH}-${PV}"
-
-DEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/pybind11[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- rmdir third_party/eigen || die
- cp -r "${WORKDIR}/eigen-${EIGEN_CommitId}" third_party/eigen || die
- distutils-r1_python_prepare_all
-}