summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-07 09:24:29 +0100
commitfa77846c708f4d0541b610846a5f2ed14b4b20c1 (patch)
tree35860ca9d75749380daddffe86bbd70d3c5866a9 /dev-python/mkdocstrings-python
parent640c4638f1e12a2c71f539ee18564a0c82d19947 (diff)
gentoo auto-resync : 07:08:2023 - 09:24:28
Diffstat (limited to 'dev-python/mkdocstrings-python')
-rw-r--r--dev-python/mkdocstrings-python/Manifest2
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index e7a2fdee586e..9142f98735d5 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1,3 +1,5 @@
DIST mkdocstrings-python-1.2.1.gh.tar.gz 132468 BLAKE2B 287cae20510818c085bf505fea0f74e39df86538e19bfcb90aa7f6d46fb237158979dc65c7f955d73461fadb4ed35263ef47b9771f224b5793026a9f0b3c86e1 SHA512 147849a88c3bb5347c1cb4293c9ee9c54cb33933bc274dc5bc933f72deb64016c7f7b8ba817311e282c68606d0980571d5713dec7a47e8d6c51168d524af7d97
+DIST mkdocstrings-python-1.3.0.gh.tar.gz 132776 BLAKE2B 894068067f301f40ed9535cd929fdbd40aa396c9c09c0cee7887f50669465cd0422c0b9b240553193df7e7d4c90f0bf2b591000e6568ee3c47256fc5d1f79179 SHA512 caf806d6285281ef84ed78bd6295ec6732d454a602f55f825436d0a17e9ab62e33ac21510d0ccee5d33fb3c117ec416859ad90ce75d608649a277342d1dc5a1c
EBUILD mkdocstrings-python-1.2.1.ebuild 861 BLAKE2B 7c7c0491dc73801d217fcac26f68c768599c81c5abd64dcbbe41dae2ede7ce3906289d520b3f3b06c83d89aede77f5648036f4e845e11b30941700d7ed5cc30d SHA512 8d9be4de760da3db801a607085342c35dd8bd448ecda072446367340805a8eb046a15b5bb5a89c3621ba8c25ccfceb0eb7bf0102ed42a323e52b5814db66209a
+EBUILD mkdocstrings-python-1.3.0.ebuild 904 BLAKE2B 81b1b24e019f3a0ca5f1985ac5360bd00e0597d319ef2b27a3dde4ebcf1d189d285cd5466d1cc2e8ce91d4a9ed4f4572b3b490c04820a44ecbed500ca02d6a9a SHA512 75c785a810d602c15c8e852e3baf9578c1bed623071c026d9040f1e2a62bae2273af7c133a61d1e02c2d07a4a8db0a79a8f494625e0cbc720b56772ec1aa7606
MISC metadata.xml 411 BLAKE2B 0ac98abc8de945139a73e2083e8c04df749bd8c0c26c446df65218057182391ae025885fa5c5bde2d1139dde9916aa3baa0426d70b57326563c3fdaf466a20d8 SHA512 c7ec032c8ae7197452714dc2b541ccad1cf84d7844dafc4e7581ffb00c62c0fd2c38d453e62a7706d74d2d20146acdf1e99e502ab8bd8976acfd6f5a605e1c56
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild
new file mode 100644
index 000000000000..17104df0a441
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ <dev-python/griffe-0.33[${PYTHON_USEDEP}]
+ >=dev-python/griffe-0.30.0[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}