summaryrefslogtreecommitdiff
path: root/dev-python/mkdocstrings-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-21 23:10:38 +0000
commit51a01b0f2371b8dfc39f2747ecafd7d5f083ecb4 (patch)
tree55d5c62353eb98ea2809ea087e9fc4b215c53563 /dev-python/mkdocstrings-python
parent46de1a2f454a1465026d681f5dfe8db7dde5b126 (diff)
gentoo auto-resync : 21:11:2023 - 23:10:38
Diffstat (limited to 'dev-python/mkdocstrings-python')
-rw-r--r--dev-python/mkdocstrings-python/Manifest2
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.7.5.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index 38a8730d41a3..d568ebd317df 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1,5 +1,7 @@
DIST mkdocstrings-python-1.7.3.gh.tar.gz 136488 BLAKE2B 470f7d69819222a9c1620f5a5ab57a9e884bc9cb1e4d536f35458c0f4c08c5442da1d31522665077ee848e2b241c7fa50ae3a73f5f570599fadb0ee9f2fcc2f8 SHA512 d5c5e9eeaa13a951cffe4fdc6f9a6bf6e3e3cb0615f7180db91446c6e8060c061682e5d717616d8dbf66009a650d363b25a4124b750f760e60bd1ffdca8e0164
DIST mkdocstrings-python-1.7.4.gh.tar.gz 139739 BLAKE2B 31e88172d745c165aa13b27078118e0a877f1bd70336d35d43ce57ec1ac5ca8b019a588491e2544b8413252a236d872c91af41b63996d8d6878975d45f3739a1 SHA512 a6445ae3e20117c73b3f3d1bc673fe6824790622931cf1fc0f1178456a9b331a514146e56c279cb046a6e50bb43da2f20abab93441359a183f06ffa794d8b1b2
+DIST mkdocstrings-python-1.7.5.gh.tar.gz 140386 BLAKE2B dec768e60ca09befe8f790bf211960222b45319cdbf00a97c072cb18b42ccfd71ac41079a7a0bdb9a94ff562181290d309a3e69f3cebc4f7b86e05553381d655 SHA512 6d595b777d4ff1661301fda7fa198bdafb7f62b356bdf5e579b808dda1f33a8f29e266be0bf51da52bc41cbbf3b0544a65750fc67d545b3dae7634798d0f3bf9
EBUILD mkdocstrings-python-1.7.3.ebuild 859 BLAKE2B 926a9c55b502d6313dee12dfe777e90ca9573eb787b2fe5129e29c99a034e42f649ef64bead7de1beb3f4a97d1b1b1a5ed2a18bb7989e7d62e750a4f39b72cff SHA512 6a66967c086389d4d6cc7573a1b3c55926fb16cc1545f0c4fa3c89aeb94d4639edeeb2cafe7002a4a28e4eb68f8c8d90e0960a5620f2f3810b4d54df2540d578
EBUILD mkdocstrings-python-1.7.4.ebuild 859 BLAKE2B 4ee21a97dc9f86543ea87b2dfeeda75bdf55358a647c6bdf786c0eac9dceda695be8beb87ad373b136af783431c0262f8785f93a4a22a1466bcabcd961b39f43 SHA512 36c9c4459afeba6b9c4556e3679bdc7b0b2dc2710054dc9df0b30343df32ebd440932242fccd3e7a86eeead12aa2152a1a07b9537c3e0e56379f2ecb49a3086f
+EBUILD mkdocstrings-python-1.7.5.ebuild 859 BLAKE2B 4ee21a97dc9f86543ea87b2dfeeda75bdf55358a647c6bdf786c0eac9dceda695be8beb87ad373b136af783431c0262f8785f93a4a22a1466bcabcd961b39f43 SHA512 36c9c4459afeba6b9c4556e3679bdc7b0b2dc2710054dc9df0b30343df32ebd440932242fccd3e7a86eeead12aa2152a1a07b9537c3e0e56379f2ecb49a3086f
MISC metadata.xml 411 BLAKE2B 0ac98abc8de945139a73e2083e8c04df749bd8c0c26c446df65218057182391ae025885fa5c5bde2d1139dde9916aa3baa0426d70b57326563c3fdaf466a20d8 SHA512 c7ec032c8ae7197452714dc2b541ccad1cf84d7844dafc4e7581ffb00c62c0fd2c38d453e62a7706d74d2d20146acdf1e99e502ab8bd8976acfd6f5a605e1c56
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.5.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.5.ebuild
new file mode 100644
index 000000000000..4d15ba60abef
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.7.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/griffe-0.37[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}