summaryrefslogtreecommitdiff
path: root/dev-python/mkdocs-monorepo-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 04:18:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 04:18:34 +0100
commitd84be18029b166ee26fe5416098974a8d05b2983 (patch)
tree0fbc3087c3911f2ac23f738e4f43fcc77cc40386 /dev-python/mkdocs-monorepo-plugin
parent4242446a1af7d38662da76b31d2e6254d64706ec (diff)
gentoo auto-resync : 08:07:2023 - 04:18:34
Diffstat (limited to 'dev-python/mkdocs-monorepo-plugin')
-rw-r--r--dev-python/mkdocs-monorepo-plugin/Manifest3
-rw-r--r--dev-python/mkdocs-monorepo-plugin/metadata.xml13
-rw-r--r--dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild33
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/mkdocs-monorepo-plugin/Manifest b/dev-python/mkdocs-monorepo-plugin/Manifest
new file mode 100644
index 000000000000..a889c92fbbd5
--- /dev/null
+++ b/dev-python/mkdocs-monorepo-plugin/Manifest
@@ -0,0 +1,3 @@
+DIST mkdocs-monorepo-plugin-1.0.5.tar.gz 9510 BLAKE2B 96b63fabe344f99aaefd0d3d0f547f0695fcee5b7f6d5ce027fc52ef27c1a70353c3835d0a0d02c753c48a67123bc6776a8060fa0a07640ca26f008df8f3611d SHA512 ed3c011d9a7b5a32868a4a16cbdfa1fd4ce036da2d73d59645aa5f42895f12ce7fe6d1681b53d72248b09fbdb343b2cfad3846e7005dbc8977c7ae40b8e29b30
+EBUILD mkdocs-monorepo-plugin-1.0.5.ebuild 876 BLAKE2B 9ea6cdd1b0d7aaa5cf5bc23e80301b5fdaac5d977f3057770527bcdb58bb360ef9a1175edf17065017e28a37bb540d17f1ed281394fa5aff941a347419f9389c SHA512 8e6518d0d6be5d7993c21eec66c77e5d385ed0d8ff4cd5310b3e8c17111017ed0b0cfe5df4db6375f6ca01dfbb0d381f1f57abe3f2be7cf115d8c347cb54c8fb
+MISC metadata.xml 427 BLAKE2B 547ba024501ca9073fbd53d272f3fb1992ca0f0e3a9bf640d077125735f9792840b21b40165532976ec14a63d30722907c318008ea224f82a14dd4c2d32f0ca2 SHA512 663c49070591ec88eb0c530cd18a1c2b8a19ad44902d71251d147505658b6779e5c13507419c0a9688a8c454f2d3c58fa43e898f0a47abcbe715ca8c6285d3c7
diff --git a/dev-python/mkdocs-monorepo-plugin/metadata.xml b/dev-python/mkdocs-monorepo-plugin/metadata.xml
new file mode 100644
index 000000000000..62f26ac9e62a
--- /dev/null
+++ b/dev-python/mkdocs-monorepo-plugin/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">mkdocs-monorepo-plugin</remote-id>
+ <remote-id type="github">backstage/mkdocs-monorepo-plugin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild b/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild
new file mode 100644
index 000000000000..e0e42827eeb2
--- /dev/null
+++ b/dev-python/mkdocs-monorepo-plugin/mkdocs-monorepo-plugin-1.0.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build multiple documentation folders in a single Mkdocs"
+HOMEPAGE="
+ https://backstage.github.io/mkdocs-monorepo-plugin/
+ https://pypi.org/project/mkdocs-monorepo-plugin/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/mkdocs-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-4.0.1[${PYTHON_USEDEP}]
+"
+
+# Data files required by this test are not included in PyPI tarballs,
+# and upstream has not tagged any releases in their GitHub repository since 2019.
+EPYTEST_DESELECT=(
+ mkdocs_monorepo_plugin/tests/test_plugin.py::TestMonorepoPlugin::test_plugin_on_config_with_nav
+)
+
+distutils_enable_tests pytest