summaryrefslogtreecommitdiff
path: root/dev-python/mistune/mistune-3.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-10 09:50:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-10 09:50:45 +0100
commit3d00647fec2600e217d690a64ba45a41f1a2fa0c (patch)
tree372903cfdc422592f1c2b4df752276358d1e7984 /dev-python/mistune/mistune-3.0.1.ebuild
parente0b23919d82070530276a893043523d8084be1e8 (diff)
gentoo auto-resync : 10:06:2023 - 09:50:45
Diffstat (limited to 'dev-python/mistune/mistune-3.0.1.ebuild')
-rw-r--r--dev-python/mistune/mistune-3.0.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/mistune/mistune-3.0.1.ebuild b/dev-python/mistune/mistune-3.0.1.ebuild
new file mode 100644
index 000000000000..cebb95e81025
--- /dev/null
+++ b/dev-python/mistune/mistune-3.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="
+ https://github.com/lepture/mistune/
+ https://pypi.org/project/mistune/
+"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest