summaryrefslogtreecommitdiff
path: root/dev-python/minikanren/minikanren-1.0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
commit99b2c44c1425c7b2925846d4c44b2bf2f78dc786 (patch)
tree9bf7a2d385aace0ea5f3f8d3e3657168b758fdaa /dev-python/minikanren/minikanren-1.0.3-r1.ebuild
parent39bccce90513402ec93bb0fde30678f16b07a9cc (diff)
gentoo auto-resync : 08:07:2023 - 22:23:22
Diffstat (limited to 'dev-python/minikanren/minikanren-1.0.3-r1.ebuild')
-rw-r--r--dev-python/minikanren/minikanren-1.0.3-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/minikanren/minikanren-1.0.3-r1.ebuild b/dev-python/minikanren/minikanren-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..8f8f6317b8a8
--- /dev/null
+++ b/dev-python/minikanren/minikanren-1.0.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=kanren-${PV}
+DESCRIPTION="Relational programming in Python"
+HOMEPAGE="
+ https://pypi.org/project/miniKanren/
+ https://github.com/pythological/kanren/
+"
+SRC_URI="
+ https://github.com/pythological/kanren/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/etuples[${PYTHON_USEDEP}]
+ dev-python/logical-unification[${PYTHON_USEDEP}]
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest