summaryrefslogtreecommitdiff
path: root/dev-python/minidb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/minidb
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/minidb')
-rw-r--r--dev-python/minidb/Manifest5
-rw-r--r--dev-python/minidb/metadata.xml13
-rw-r--r--dev-python/minidb/minidb-2.0.1-r1.ebuild27
-rw-r--r--dev-python/minidb/minidb-2.0.2.ebuild27
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/minidb/Manifest b/dev-python/minidb/Manifest
new file mode 100644
index 000000000000..d7d27a9741da
--- /dev/null
+++ b/dev-python/minidb/Manifest
@@ -0,0 +1,5 @@
+DIST minidb-2.0.1.tar.gz 13848 BLAKE2B 4aeea547693ccb8a67fba147b640535952402dce8b97c6aa1a78ce92997ddfbfc34ecbc4d444eedfd7b3ddcfe71841777eba0bb2fbdeba49114032baaea9c0a6 SHA512 98be264ba669ef08f180c469ca8375540436244228ee4e0c4e4b0511425b909eb4c64dc812a27d0b490af5972e0897538f905590b7d2dd19f6fdd160280a6b4b
+DIST minidb-2.0.2.tar.gz 13928 BLAKE2B 7b6997bd0ed852561c1a45e1d8f63030798c59ebbe67ba3e9f38c08eddcf22028756b17c5ce8aa460e5d3113ef54cdafe782cb471aabfe208b093af702694cb7 SHA512 92879d6df61b0f9f72f9fe8f1cf38d559477983c6bba8c88ed02289570daff02f6f8d7010c0a95ffce049ab67be69323c47caefdfe3a8b008038377235ed9a5f
+EBUILD minidb-2.0.1-r1.ebuild 563 BLAKE2B 9e01a62bafb71239cbb8aa6217cce89cade482f102fff3b5c92f5523cf6923714221ddaafee8fa0be4fcfaebdde0b3d0e18026892c5899d8c39607c841f6114b SHA512 571131713ccadc1210ac7a23e6df6432577293d106a2691a25174002f0b3dffd2a885d0d16940532567ac365cab11498ec4df9970e5b28d662a800e9e6fabea5
+EBUILD minidb-2.0.2.ebuild 563 BLAKE2B 858035f5a1ada7d6a387cf9c3735a45cd6527b30845777187757a77998bc7a5ec9ba8d5b795e04c28138708b79c0270dee42f0e677e0743257f33aefe681e25d SHA512 b7c99fb50d1041497ce832053e7cee1c9af0527f536b7868d94b6d29d675c2e0089bbbf1c35b9a6477bb8138bd1f4918b4677d530259b98f5e3d214ef25885a6
+MISC metadata.xml 422 BLAKE2B b5d93a5b4470c716205ec803434d612c404f45c9b6ee708a56d57ea120c423cfa86f008bc47ef0690836b3cc92c6eae56c3b97959671d6ea72ad751868d3d94c SHA512 c2b0dbbbabedccc7036eecfd09f403f9a5848c6f71d09a12e5be773506c6ec5a5290f459e8cea9505abcd438e47ff84f8c32ffacf6a62be365bbf8c92f6c64d0
diff --git a/dev-python/minidb/metadata.xml b/dev-python/minidb/metadata.xml
new file mode 100644
index 000000000000..91fac9f6e930
--- /dev/null
+++ b/dev-python/minidb/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">minidb</remote-id>
+ <remote-id type="github">thp/minidb</remote-id>
+ <bugs-to>https://github.com/thp/minidb/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/minidb/minidb-2.0.1-r1.ebuild b/dev-python/minidb/minidb-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..33437a219865
--- /dev/null
+++ b/dev-python/minidb/minidb-2.0.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Simple SQLite-based object store"
+HOMEPAGE="https://thp.io/2010/minidb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests test || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/minidb/minidb-2.0.2.ebuild b/dev-python/minidb/minidb-2.0.2.ebuild
new file mode 100644
index 000000000000..8648a165355d
--- /dev/null
+++ b/dev-python/minidb/minidb-2.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Simple SQLite-based object store"
+HOMEPAGE="https://thp.io/2010/minidb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests test || die "tests failed with ${EPYTHON}"
+}