summaryrefslogtreecommitdiff
path: root/dev-python/minidb/minidb-2.0.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-25 23:59:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-25 23:59:45 +0100
commit6243676c91946098c06d42bc87b5eb99aac40bf0 (patch)
treee6de308ba22148b4898b67b049c7f017ece8fea2 /dev-python/minidb/minidb-2.0.8.ebuild
parentb987a550f067c3da93b0664cf1fdc8a624c0aa38 (diff)
gentoo auto-resync : 25:04:2024 - 23:59:45
Diffstat (limited to 'dev-python/minidb/minidb-2.0.8.ebuild')
-rw-r--r--dev-python/minidb/minidb-2.0.8.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/minidb/minidb-2.0.8.ebuild b/dev-python/minidb/minidb-2.0.8.ebuild
new file mode 100644
index 000000000000..fade9deceb5d
--- /dev/null
+++ b/dev-python/minidb/minidb-2.0.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple SQLite-based object store"
+HOMEPAGE="
+ https://thp.io/2010/minidb/
+ https://pypi.org/project/minidb/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest