summaryrefslogtreecommitdiff
path: root/dev-python/milk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-python/milk
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-python/milk')
-rw-r--r--dev-python/milk/Manifest3
-rw-r--r--dev-python/milk/metadata.xml26
-rw-r--r--dev-python/milk/milk-0.6.1.ebuild27
3 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/milk/Manifest b/dev-python/milk/Manifest
deleted file mode 100644
index 40c5f0e1658d..000000000000
--- a/dev-python/milk/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST milk-0.6.1.tar.gz 628357 BLAKE2B ea781b87aed1ed2b20d8eea16efe3cfc1e9777144e8847ea8617f2de3ee523cc3a9dbb54879206e146924487a10d41302e01d6fa78c812c8c5523b360cdd1e5c SHA512 54a94bc1bf760320b53b2f65396e117bdccd0d4d5e6bdb4684b68d96f3cb3beaf3cc9b285d3ba91b1f97ba335750591c1fb2d2115468ec617dbd1cc65fed9f8f
-EBUILD milk-0.6.1.ebuild 654 BLAKE2B 3490105bc9bb3d8fb2f01ddbce33a5efc82fbc42db5b29f2428a8cd0dfd3da4d4bc0cf4b2dc92aff1290e5fd165deba736d314c1cee0c4c936a334986b155b53 SHA512 5bd3777cfe11bfc5b9dfe5aeb3b602921aedbd2186f60d0f33d086cd2e84ac3b54dfbe98a00d863aa826c41d334b216bf2b6c684c8e54fe5ec2e4edbd2d17fee
-MISC metadata.xml 1152 BLAKE2B b772ced54839c36c070780303aee01a876af081e17883e97176e422c447e5da8878fe0a19fbce00267bfbdbc01ccdfd91472763a6a6c87e492bd41b094c62b49 SHA512 c4d9d5d7774abd15d165107798995a5fe4de13ba96342fbc1c8987876df7133846ca94383942812945e6bea62c9bf8f34073bf264842e58a3e70d181273c640f
diff --git a/dev-python/milk/metadata.xml b/dev-python/milk/metadata.xml
deleted file mode 100644
index 320bb4cda904..000000000000
--- a/dev-python/milk/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>sci@gentoo.org</email>
- <name>Gentoo Science Project</name>
-</maintainer>
-<longdescription lang="en">
- Milk is a machine learning toolkit in Python.
- Its focus is on supervised classification with several classifiers
- available: SVMs (based on libsvm), k-NN, random forests, decision
- trees. It also performs feature selection. These classifiers can be
- combined in many ways to form different classification systems.
- For unsupervised learning, milk supports k-means clustering and
- affinity propagation.
- Milk is flexible about its inputs. It optimised for numpy arrays, but
- can often handle anything (for example, for SVMs, you can use any
- dataype and any kernel and it does the right thing).
- There is a strong emphasis on speed and low memory usage. Therefore,
- most of the performance sensitive code is in C++. This is behind
- Python-based interfaces for convenience.
-</longdescription>
-<upstream>
- <remote-id type="pypi">milk</remote-id>
-</upstream>
-</pkgmetadata>
diff --git a/dev-python/milk/milk-0.6.1.ebuild b/dev-python/milk/milk-0.6.1.ebuild
deleted file mode 100644
index f0cea5d438f3..000000000000
--- a/dev-python/milk/milk-0.6.1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Machine learning toolkit in Python"
-HOMEPAGE="http://luispedro.org/software/milk"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- || (
- dev-python/numpy-python2[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- dev-cpp/eigen:3
- test? ( dev-python/milksets sci-libs/scipy[${PYTHON_USEDEP}] )"