summaryrefslogtreecommitdiff
path: root/dev-python/meson-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-06 19:22:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-06 19:22:30 +0100
commit744892aecb5cdf9ca0bbe504f7bbcdfb87b518fc (patch)
tree0b99b178b866e693a85d013eb47de3d1236e35b8 /dev-python/meson-python
parent275074c50dca7b941cc7cd7966a2ace71c29ecae (diff)
gentoo auto-resync : 06:10:2022 - 19:22:30
Diffstat (limited to 'dev-python/meson-python')
-rw-r--r--dev-python/meson-python/Manifest2
-rw-r--r--dev-python/meson-python/meson-python-0.10.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/meson-python/Manifest b/dev-python/meson-python/Manifest
index a010f1eaf7b7..42f7e5bea5a2 100644
--- a/dev-python/meson-python/Manifest
+++ b/dev-python/meson-python/Manifest
@@ -1,4 +1,6 @@
AUX meson-python-0.7.0-defaults.patch 506 BLAKE2B 404c8d4803f4e6ca5244dc27c84f2c0440999e3fff87febeb12d1d304c7ed9f9358f6b958b5975d171995960bbf7681003180765d2bdb88e694e52c518a8381d SHA512 43b9825b9facdcf72f0b4b80a72aac8544ec1cedb14a79c53dbe37b190af170584acbb0d281d89ddeb199ea5ba720eb0de04c5294a3e7197019c58d7ee14d786
+DIST meson-python-0.10.0.gh.tar.gz 37739 BLAKE2B 028cbb191076b49946576b02d26a84079f412a178d9829bf85d579b8d3624e192e9394ade31524faf972ef4d105b7bf703e750529a7fafcbadf9a52d3c4876c6 SHA512 50d4d0bbf810948b4f218f25815058778b2a3ac8ff811d4d7cc699d1cfbcb75612d28789080b4e5ec3a47be03636389b7bf313366273abb733f77644758747cb
DIST meson-python-0.9.0.gh.tar.gz 37253 BLAKE2B 29aa875dfc1c275ee4edab48bd2d46c783969fc0ab58f108be1a6443d5519028a2d36f666dc57c45d68ba77334cca2d11a0d4bfb8abb3822b537252c71b77286 SHA512 ae0927876533af65c5b1d8278ff6db3726f0551c160bfedcc602189fcad44c9412faa589738718aac2f10cf9497db8c632d89ccf1fb8519e6e7f4add78d8e52d
+EBUILD meson-python-0.10.0.ebuild 988 BLAKE2B 6e2465b93b4de894ced85af09ff9e227c0a466a99551f51ef5c8f8f72475c6c9fe28c4a707c2f3ce8a3a393de2ec3ac80d26d477bab9584a91b533dd13206953 SHA512 9b5affd60de454a84150808d87c13b85ceb778558f5dd4c1a6fe74d37868aaccca355e4d6a4991420bf6444a1afed476791012745a85a4fa2fe5f657c7670b58
EBUILD meson-python-0.9.0.ebuild 988 BLAKE2B 6e2465b93b4de894ced85af09ff9e227c0a466a99551f51ef5c8f8f72475c6c9fe28c4a707c2f3ce8a3a393de2ec3ac80d26d477bab9584a91b533dd13206953 SHA512 9b5affd60de454a84150808d87c13b85ceb778558f5dd4c1a6fe74d37868aaccca355e4d6a4991420bf6444a1afed476791012745a85a4fa2fe5f657c7670b58
MISC metadata.xml 352 BLAKE2B 581fd656bf2da3af0cb7a9f50ef99effc9c2fc54c5012a363a3aaf4cb5cb1715c8626aed86ea176ebbbc22ece33e8b0f76d5c818b4533f99b3bac5b92f75fff1 SHA512 7e57debaea115565ade7e8ab87af065c4580506225df1a203c92fea877a9b918ebfce6fd172412bf318be07a8a4548be492318e5626b31688ed2714f00594d54
diff --git a/dev-python/meson-python/meson-python-0.10.0.ebuild b/dev-python/meson-python/meson-python-0.10.0.ebuild
new file mode 100644
index 000000000000..5ca1c9027a37
--- /dev/null
+++ b/dev-python/meson-python/meson-python-0.10.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Meson PEP 517 Python build backend"
+HOMEPAGE="
+ https://pypi.org/project/meson-python/
+ https://github.com/FFY00/meson-python/
+"
+SRC_URI="
+ https://github.com/FFY00/meson-python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+
+RDEPEND="
+ >=dev-python/pyproject-metadata-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.0.0[${PYTHON_USEDEP}]
+ >=dev-util/meson-0.63.0[${PYTHON_USEDEP}]
+ dev-util/patchelf
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.0-defaults.patch
+)
+
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/sphinx-autodoc-typehints
+distutils_enable_tests pytest