summaryrefslogtreecommitdiff
path: root/dev-python/memory_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/memory_profiler
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest4
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.59.ebuild55
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.60.ebuild4
3 files changed, 3 insertions, 60 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
index c9a355c4e227..823103627ac2 100644
--- a/dev-python/memory_profiler/Manifest
+++ b/dev-python/memory_profiler/Manifest
@@ -1,5 +1,3 @@
-DIST memory_profiler-0.59.gh.tar.gz 142586 BLAKE2B b9c8cffbd03f980937d30626facf431e6effd9a86a21fbe629f4238a2f78f2d65242637105ad3a07b4158a6335a541701bba657941bb23c9da0f49a1113402ee SHA512 f70ad8f871bd5068e2817049231abee7e535cb352f0444dcb0d9d072b9f4dda944e85ec7854855307a9748257da80f53dd50fe17fefbd73045dce1306f51f88d
DIST memory_profiler-0.60.gh.tar.gz 142585 BLAKE2B aa7fd9e547eecadc184d4da5830c582a9a9ab9565f3dc9c763caaa7e75698ed6b499d2555e4a93b39d2f80f85fad025b84043e0812cb25dd1511f4ebf8da5a85 SHA512 407e44a410cdb4c7c8cc5ff40198c28012f8b0c6bba88d2d1612681eb621a1b802ef137be62fc64ca9e3c362ca3814433bc12169d7c3827bf97293c5bbb8bfbc
-EBUILD memory_profiler-0.59.ebuild 1788 BLAKE2B c880040bb2fd76f91e449527770a8b9c669e6383fde69b481e9613046d27070aae7e1b6c7079d5f0c77a077c090516a87e2c1878834832a818f9a07c3bc5323b SHA512 43f02d01b7a2aaf22620d1bb1f17cf2c3c562b1166b111365d9b81c7d4b82f0e67b674bc5eed26663a09a3584a485d17740d245a63fcc95b0d063383ce280c36
-EBUILD memory_profiler-0.60.ebuild 1790 BLAKE2B 7a518d001564b1f62e035fa6b1a4821d0b33afb13eac9e58b58f76d40d8f1195de7a9a4e8afee3c486cbe8f2896d2782dada32d097ed70b59865e1e56ef0b832 SHA512 6970839762eb5d606f826cd185a88f5ed318833df375c06dcfc0948ed127ce01ab9242b93c5365b62e6960661668c6de70a871608ac453740e2b46b20b9deb08
+EBUILD memory_profiler-0.60.ebuild 1788 BLAKE2B c880040bb2fd76f91e449527770a8b9c669e6383fde69b481e9613046d27070aae7e1b6c7079d5f0c77a077c090516a87e2c1878834832a818f9a07c3bc5323b SHA512 43f02d01b7a2aaf22620d1bb1f17cf2c3c562b1166b111365d9b81c7d4b82f0e67b674bc5eed26663a09a3584a485d17740d245a63fcc95b0d063383ce280c36
MISC metadata.xml 548 BLAKE2B 744d692e6a44ddb587b1ae69c5f6ff48fa0f02b8acadcaee34242f810d1404fc6b3c4493a257a70b3af21850e08a17a8ee3758ae9e8af1937b645a2968b5d4c0 SHA512 b7872bfa470fb34a4d60bb9ee976d5a62122b0b701635e305988660952e695f52d9d4f0227518dc9fb337b4a3f6a95dc11b5298f1787ddd100b3f46c34f812fe
diff --git a/dev-python/memory_profiler/memory_profiler-0.59.ebuild b/dev-python/memory_profiler/memory_profiler-0.59.ebuild
deleted file mode 100644
index e95aa5f7afbe..000000000000
--- a/dev-python/memory_profiler/memory_profiler-0.59.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A module for monitoring memory usage of a python program"
-HOMEPAGE="https://pypi.org/project/memory-profiler/ https://github.com/pythonprofilers/memory_profiler"
-SRC_URI="
- https://github.com/pythonprofilers/memory_profiler/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-IUSE="examples"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-
-# dev-lang/mercury: collision on 'mprof'
-# https://bugs.gentoo.org/571176
-RDEPEND="dev-python/psutil[${PYTHON_USEDEP}]
- !dev-lang/mercury"
-
-distutils_enable_tests pytest
-
-python_test() {
- "${EPYTHON}" -m memory_profiler test/test_as.py || die
- "${EPYTHON}" -m memory_profiler test/test_func.py || die
- "${EPYTHON}" -m memory_profiler test/test_gen.py || die
- "${EPYTHON}" -m memory_profiler test/test_loop.py || die
- "${EPYTHON}" -m memory_profiler test/test_loop_decorated.py || die
- "${EPYTHON}" -m memory_profiler test/test_mprofile.py || die
- "${EPYTHON}" -m memory_profiler test/test_nested.py || die
- "${EPYTHON}" -m memory_profiler test/test_precision_command_line.py || die
- "${EPYTHON}" -m memory_profiler test/test_unicode.py || die
-
- "${EPYTHON}" test/test_exception.py || die
- "${EPYTHON}" test/test_exit_code.py || die
- "${EPYTHON}" test/test_global.py || die
- "${EPYTHON}" test/test_import.py || die
- "${EPYTHON}" test/test_memory_usage.py || die
- "${EPYTHON}" test/test_mprof.py || die
- "${EPYTHON}" test/test_precision_import.py || die
- "${EPYTHON}" test/test_stream_unicode.py || die
- "${EPYTHON}" test/test_tracemalloc.py || die
-}
-
-python_install_all() {
- use examples && dodoc -r examples
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/memory_profiler/memory_profiler-0.60.ebuild b/dev-python/memory_profiler/memory_profiler-0.60.ebuild
index afc8e46ebfb4..e95aa5f7afbe 100644
--- a/dev-python/memory_profiler/memory_profiler-0.60.ebuild
+++ b/dev-python/memory_profiler/memory_profiler-0.60.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,7 +17,7 @@ IUSE="examples"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
# dev-lang/mercury: collision on 'mprof'
# https://bugs.gentoo.org/571176