summaryrefslogtreecommitdiff
path: root/dev-python/memory_profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-python/memory_profiler
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-python/memory_profiler')
-rw-r--r--dev-python/memory_profiler/Manifest2
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.54.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/memory_profiler/Manifest b/dev-python/memory_profiler/Manifest
index 4305213bf8cf..408381d3da75 100644
--- a/dev-python/memory_profiler/Manifest
+++ b/dev-python/memory_profiler/Manifest
@@ -1,3 +1,5 @@
DIST memory_profiler-0.47.tar.gz 33725 BLAKE2B 66fc0e5c579febeea9dcd5132caa6fdbccdb5cb0a2c9083f5abf8aa03baaaafe1f77f72cdbe4d5384c6ce27fd4760511f9a947fda46eee1d81e7125c1dcd2970 SHA512 110e16ecad33068d31cf53b2f0b775d65230d51345f24a4d7d3cafafb706b10a0c7e2d98a799256b0366f1bafa9b69c060222595bb4eb9e1689301428a36fc3d
+DIST memory_profiler-0.54.0.tar.gz 31376 BLAKE2B 4c89a046bdce36a139448dde45c8cf952aaa8fe8e2089bf9574a8fb2ed1abb89991e54f59742b0ea1ae5315378c0799ef140752549f9a8d13a91bf0ceb021984 SHA512 ec5735b7e41e706ea35ce9fe0dd3963c51e50e5bdf7f1871c51bbbb2a0ae75abcdba23abd3a14979c26ce19e7ce7d2cf6782aefc77e0c17cfe4da573a6e249ae
EBUILD memory_profiler-0.47.ebuild 1235 BLAKE2B 9a10cb80fb9381a1e01d323ac993f6345188dadcfbbaa5d5e44ea480bafb23443260e8c47dd14383c96c8060baf6c7ae3cc5eb8eff1fa39252c5b1915190b514 SHA512 aa3fe3d37492689b2b349c81e2e3a64d6fcf2aca4c0955ded24ae01b5eedce55f4dd9f7c5ec380e8e7362b53d0f1649806b5468637bb6f4c1640b9626ccfa4ba
+EBUILD memory_profiler-0.54.0.ebuild 1223 BLAKE2B 3b1b9f9e051389140418fc23bbbb82e01711fb09cf0efee8ca116ae12a892287849e044bc5e9291540a49fbb3a0f81b1200fd663cce943a3c59901e533826d1f SHA512 a0552bc2490c0167e8a396d4ef235949b7d3cdb4cc8716c3ec43cb567c7cb60e4304a6112074a18a2cfd3e311cbd037d41c2d81c0a0368b0901b89c4a1f474c8
MISC metadata.xml 514 BLAKE2B 9721c8c8ab0f05e50b0d3d9fe16e0392aaa513177abdd4318aa2b10c70a656627e054b0a162eb7324e9b20e8f74dd1c3f3fbf4aa456fe98a34899525e3d9ad5a SHA512 cedc4d8914ad8cf10c8981935089220967957ff50eecfd867376974055d4922df91357a2f2135ce3cf5f56a27c5111005ae53429e685f0ee080e031bb2a3e943
diff --git a/dev-python/memory_profiler/memory_profiler-0.54.0.ebuild b/dev-python/memory_profiler/memory_profiler-0.54.0.ebuild
new file mode 100644
index 000000000000..905633999611
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.54.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="https://pypi.org/project/memory_profiler/ https://github.com/fabianp/memory_profiler"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} -m memory_profiler test/test_func.py || die
+ ${EPYTHON} -m memory_profiler test/test_loop.py || die
+ ${EPYTHON} -m memory_profiler test/test_as.py || die
+ ${EPYTHON} -m memory_profiler test/test_global.py || die
+ ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
+ ${EPYTHON} -m memory_profiler test/test_gen.py || die
+ if python_is_python3; then
+ ${EPYTHON} -m memory_profiler test/test_unicode.py || die
+ fi
+ ${EPYTHON} test/test_tracemalloc.py || die
+ ${EPYTHON} test/test_import.py || die
+ ${EPYTHON} test/test_memory_usage.py || die
+ ${EPYTHON} test/test_precision_import.py || die
+}