summaryrefslogtreecommitdiff
path: root/dev-python/memory_profiler/memory_profiler-0.61.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-17 12:56:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-17 12:56:42 +0000
commit34fb4543abc1dae6f74171ad8dc80fa64636a941 (patch)
tree5923cd4dc2a560dba9b618db67713ae10cf92f75 /dev-python/memory_profiler/memory_profiler-0.61.ebuild
parent1536d928ae095e00db8775fecca580c10adc0af8 (diff)
gentoo auto-resync : 17:11:2022 - 12:56:42
Diffstat (limited to 'dev-python/memory_profiler/memory_profiler-0.61.ebuild')
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.61.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/memory_profiler/memory_profiler-0.61.ebuild b/dev-python/memory_profiler/memory_profiler-0.61.ebuild
new file mode 100644
index 000000000000..a5f150e6ca3a
--- /dev/null
+++ b/dev-python/memory_profiler/memory_profiler-0.61.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="
+ https://github.com/pythonprofilers/memory_profiler/
+ https://pypi.org/project/memory-profiler/
+"
+SRC_URI="
+ https://github.com/pythonprofilers/memory_profiler/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+# dev-lang/mercury: collision on 'mprof'
+# https://bugs.gentoo.org/571176
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ !dev-lang/mercury
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ "${EPYTHON}" -m memory_profiler test/test_as.py || die
+ "${EPYTHON}" -m memory_profiler test/test_func.py || die
+ "${EPYTHON}" -m memory_profiler test/test_gen.py || die
+ "${EPYTHON}" -m memory_profiler test/test_loop.py || die
+ "${EPYTHON}" -m memory_profiler test/test_loop_decorated.py || die
+ "${EPYTHON}" -m memory_profiler test/test_mprofile.py || die
+ "${EPYTHON}" -m memory_profiler test/test_nested.py || die
+ "${EPYTHON}" -m memory_profiler test/test_precision_command_line.py || die
+ "${EPYTHON}" -m memory_profiler test/test_unicode.py || die
+
+ "${EPYTHON}" test/test_exception.py || die
+ "${EPYTHON}" test/test_exit_code.py || die
+ "${EPYTHON}" test/test_global.py || die
+ "${EPYTHON}" test/test_import.py || die
+ "${EPYTHON}" test/test_memory_usage.py || die
+ "${EPYTHON}" test/test_mprof.py || die
+ "${EPYTHON}" test/test_precision_import.py || die
+ "${EPYTHON}" test/test_stream_unicode.py || die
+ "${EPYTHON}" test/test_tracemalloc.py || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}