summaryrefslogtreecommitdiff
path: root/dev-python/memory_profiler/memory_profiler-0.43.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-05 20:45:13 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-05 20:45:13 +0000
commit8fcdcec5fbdd0e3a77391e4f354218014f59f358 (patch)
treeb6aaf9c103052f2ab4a948377142f4a4233caa60 /dev-python/memory_profiler/memory_profiler-0.43.ebuild
parent423d21dcfee183cc4b04d29c1621615e8c30f834 (diff)
gentoo resync : 05.01.2018
Diffstat (limited to 'dev-python/memory_profiler/memory_profiler-0.43.ebuild')
-rw-r--r--dev-python/memory_profiler/memory_profiler-0.43.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/memory_profiler/memory_profiler-0.43.ebuild b/dev-python/memory_profiler/memory_profiler-0.43.ebuild
deleted file mode 100644
index 046f424b099d..000000000000
--- a/dev-python/memory_profiler/memory_profiler-0.43.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="A module for monitoring memory usage of a python program"
-HOMEPAGE="https://pypi.python.org/pypi/memory_profiler https://github.com/fabianp/memory_profiler"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- dev-python/psutil[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- ${EPYTHON} -m memory_profiler test/test_func.py || die
- ${EPYTHON} -m memory_profiler test/test_loop.py || die
- ${EPYTHON} -m memory_profiler test/test_as.py || die
- ${EPYTHON} -m memory_profiler test/test_global.py || die
- ${EPYTHON} -m memory_profiler test/test_precision_command_line.py || die
- ${EPYTHON} -m memory_profiler test/test_gen.py || die
- if python_is_python3; then
- ${EPYTHON} -m memory_profiler test/test_unicode.py || die
- fi
- ${PYTHON} test/test_tracemalloc.py || die
- ${EPYTHON} test/test_import.py || die
- ${EPYTHON} test/test_memory_usage.py || die
- ${EPYTHON} test/test_precision_import.py || die
-}