summaryrefslogtreecommitdiff
path: root/dev-python/memory-profiler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-22 21:47:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-22 21:47:11 +0100
commit9368ace94caa5cdda868a0dbb7c75a3fc7a2b911 (patch)
treea9a5e87e053b6853c703732ad8050bd895efc1ea /dev-python/memory-profiler
parentc1d361b300cff921a04bd9ae2f800bf8914559eb (diff)
gentoo auto-resync : 22:08:2023 - 21:47:11
Diffstat (limited to 'dev-python/memory-profiler')
-rw-r--r--dev-python/memory-profiler/Manifest3
-rw-r--r--dev-python/memory-profiler/memory-profiler-0.61.ebuild63
-rw-r--r--dev-python/memory-profiler/metadata.xml17
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/memory-profiler/Manifest b/dev-python/memory-profiler/Manifest
new file mode 100644
index 000000000000..85db4c2d6ee7
--- /dev/null
+++ b/dev-python/memory-profiler/Manifest
@@ -0,0 +1,3 @@
+DIST memory_profiler-0.61.gh.tar.gz 144680 BLAKE2B 418ae6e7433dd58b00c8706209a7172c31ccf57d74255aa670b271bc9d76b339bd582b48886bed7b53062abd8eb421678c911b3495de4d541b949f340aad7091 SHA512 02c70a049107ad4df635e20e22eaaa91fd4e4fd29690b0a7c314e08ed6e076bbb81f85dd97924ed35f7f0133cfd3c7e55b35400449489733beb172debe592c4e
+EBUILD memory-profiler-0.61.ebuild 1887 BLAKE2B ee2a7eb3b6cb7ad84e4f6565ef11d6a98ba0f32a9a310f44ddc6be86db6c16f34e6995c7b10b14e12fccbffab04a408d18c71435c284a4875eed8a3ba029591c SHA512 97a65940f2fea6a9d7b463d9b77f5458dc2e7e8675d2d8253b0a8d8b5401b2202d7da78c6bb944fbb7449f7456ae9da39666c4a3d32e0d30c1a8d003d499a9bf
+MISC metadata.xml 548 BLAKE2B 744d692e6a44ddb587b1ae69c5f6ff48fa0f02b8acadcaee34242f810d1404fc6b3c4493a257a70b3af21850e08a17a8ee3758ae9e8af1937b645a2968b5d4c0 SHA512 b7872bfa470fb34a4d60bb9ee976d5a62122b0b701635e305988660952e695f52d9d4f0227518dc9fb337b4a3f6a95dc11b5298f1787ddd100b3f46c34f812fe
diff --git a/dev-python/memory-profiler/memory-profiler-0.61.ebuild b/dev-python/memory-profiler/memory-profiler-0.61.ebuild
new file mode 100644
index 000000000000..fd059fb2d78e
--- /dev/null
+++ b/dev-python/memory-profiler/memory-profiler-0.61.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=memory_profiler-${PV}
+DESCRIPTION="A module for monitoring memory usage of a python program"
+HOMEPAGE="
+ https://github.com/pythonprofilers/memory_profiler/
+ https://pypi.org/project/memory-profiler/
+"
+SRC_URI="
+ https://github.com/pythonprofilers/memory_profiler/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~riscv x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+# dev-lang/mercury: collision on 'mprof'
+# https://bugs.gentoo.org/571176
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ !dev-lang/mercury
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ "${EPYTHON}" -m memory_profiler test/test_as.py || die
+ "${EPYTHON}" -m memory_profiler test/test_func.py || die
+ "${EPYTHON}" -m memory_profiler test/test_gen.py || die
+ "${EPYTHON}" -m memory_profiler test/test_loop.py || die
+ "${EPYTHON}" -m memory_profiler test/test_loop_decorated.py || die
+ "${EPYTHON}" -m memory_profiler test/test_mprofile.py || die
+ "${EPYTHON}" -m memory_profiler test/test_nested.py || die
+ "${EPYTHON}" -m memory_profiler test/test_precision_command_line.py || die
+ "${EPYTHON}" -m memory_profiler test/test_unicode.py || die
+
+ "${EPYTHON}" test/test_exception.py || die
+ "${EPYTHON}" test/test_exit_code.py || die
+ "${EPYTHON}" test/test_global.py || die
+ "${EPYTHON}" test/test_import.py || die
+ "${EPYTHON}" test/test_memory_usage.py || die
+ "${EPYTHON}" test/test_mprof.py || die
+ "${EPYTHON}" test/test_precision_import.py || die
+ "${EPYTHON}" test/test_stream_unicode.py || die
+ "${EPYTHON}" test/test_tracemalloc.py || die
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/memory-profiler/metadata.xml b/dev-python/memory-profiler/metadata.xml
new file mode 100644
index 000000000000..765b1c287e36
--- /dev/null
+++ b/dev-python/memory-profiler/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">memory-profiler</remote-id>
+ <remote-id type="github">pythonprofilers/memory_profiler</remote-id>
+ <maintainer status="unknown">
+ <email>f@bianp.net</email>
+ <name>Fabian Pedregosa</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>