summaryrefslogtreecommitdiff
path: root/dev-python/mechanize/mechanize-0.4.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/mechanize/mechanize-0.4.5.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/mechanize/mechanize-0.4.5.ebuild')
-rw-r--r--dev-python/mechanize/mechanize-0.4.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/mechanize/mechanize-0.4.5.ebuild b/dev-python/mechanize/mechanize-0.4.5.ebuild
new file mode 100644
index 000000000000..f3b42df6b85d
--- /dev/null
+++ b/dev-python/mechanize/mechanize-0.4.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Stateful programmatic web browsing in Python"
+HOMEPAGE="https://github.com/python-mechanize/mechanize"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( BSD ZPL )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND=">=dev-python/html5lib-0.999999999[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ "${PYTHON}" run_tests.py || die
+}