summaryrefslogtreecommitdiff
path: root/dev-python/mdx-gh-links/mdx-gh-links-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-23 07:52:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-23 07:52:18 +0000
commit4035d30ea0ada73d992bb7d583c0b37a053714fe (patch)
tree7a69165d1193f74105c13af2ed89082f75db7fe1 /dev-python/mdx-gh-links/mdx-gh-links-0.4.ebuild
parent686be77442c7f389d8c06c6dafb97294b819146b (diff)
gentoo auto-resync : 23:12:2023 - 07:52:17
Diffstat (limited to 'dev-python/mdx-gh-links/mdx-gh-links-0.4.ebuild')
-rw-r--r--dev-python/mdx-gh-links/mdx-gh-links-0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/mdx-gh-links/mdx-gh-links-0.4.ebuild b/dev-python/mdx-gh-links/mdx-gh-links-0.4.ebuild
new file mode 100644
index 000000000000..64765018fcfc
--- /dev/null
+++ b/dev-python/mdx-gh-links/mdx-gh-links-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=github-links-${PV}
+DESCRIPTION="An extension which adds links to GitHub users, repositories, issues and commits"
+HOMEPAGE="
+ https://github.com/Python-Markdown/github-links/
+ https://pypi.org/project/mdx-gh-links/
+"
+SRC_URI="
+ https://github.com/Python-Markdown/github-links/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/markdown-3.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest