summaryrefslogtreecommitdiff
path: root/dev-python/mdurl/mdurl-0.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-14 20:26:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-14 20:26:21 +0100
commitd4be17a40855a064f44debc16c4ec9b501547a26 (patch)
tree31803b808ed1a411f808c2203ecbf06b656ed9fd /dev-python/mdurl/mdurl-0.1.2.ebuild
parenta6b284ce6cc4682e2f879616e915f11774a183ac (diff)
gentoo auto-resync : 14:08:2022 - 20:26:21
Diffstat (limited to 'dev-python/mdurl/mdurl-0.1.2.ebuild')
-rw-r--r--dev-python/mdurl/mdurl-0.1.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/mdurl/mdurl-0.1.2.ebuild b/dev-python/mdurl/mdurl-0.1.2.ebuild
new file mode 100644
index 000000000000..2d85b0566f45
--- /dev/null
+++ b/dev-python/mdurl/mdurl-0.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Markdown URL utilities"
+HOMEPAGE="
+ https://pypi.org/project/mdurl/
+ https://github.com/executablebooks/mdurl/
+"
+SRC_URI="
+ https://github.com/hukkin/mdurl/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest