summaryrefslogtreecommitdiff
path: root/dev-python/mdit-py-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-27 21:10:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-27 21:10:49 +0100
commit3ca7a521e79841f7247feb67780a70722c997d55 (patch)
tree30b9afb1b822575d8e6ac4009489795a105a56ce /dev-python/mdit-py-plugins
parentc268590c556cb766e1ca3f55fde8a40cdde19c44 (diff)
gentoo auto-resync : 27:09:2022 - 21:10:48
Diffstat (limited to 'dev-python/mdit-py-plugins')
-rw-r--r--dev-python/mdit-py-plugins/Manifest2
-rw-r--r--dev-python/mdit-py-plugins/mdit-py-plugins-0.3.1.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/mdit-py-plugins/Manifest b/dev-python/mdit-py-plugins/Manifest
index 77049d4d0515..96e9d3aeb762 100644
--- a/dev-python/mdit-py-plugins/Manifest
+++ b/dev-python/mdit-py-plugins/Manifest
@@ -1,3 +1,5 @@
DIST mdit-py-plugins-0.3.0.gh.tar.gz 50654 BLAKE2B e84842e7cada1d9239f1d449c1a21ed654ab13017ea92f82190053b37371bc7e06d7afb65f6f56f7fa935666d24d05dca99628121bd4092a1143c289588ddfa4 SHA512 dd6aa738c6d93e45437326b1be52e0a9fc411aa3beacb61690919c272979c97ac1b38116b1ebb01c7d8fe724d4af9621c81ccd45131a690df8a2c0c325eef0e8
+DIST mdit-py-plugins-0.3.1.gh.tar.gz 53897 BLAKE2B 57bb08ec6f90d28beb10fbd57d980b1d6f7b1df5d5c3d537685ec1c34d2ea74ea9e5facd0ee432d12924ae2d35d32e3c4dc3600485486b6cd49d5568bffbf48f SHA512 a934953e95eba04f5c1626d8256fed53cbbb26e35d816b41b7aaf968b452e3bfaa99e3008009dbdd8d9e7c89497916916c2cc1fabbecb735624231cafee864ea
EBUILD mdit-py-plugins-0.3.0.ebuild 737 BLAKE2B db6237462ce2f25ec581a6548ca98aa69f73ea8cd48dd737320599b3fb8ce0c9fcfa77808359c96b31737cc3244467826778c7092cb17571e76f4441da246cd0 SHA512 ee0b16ce7180e957e2665d427f7ad9a6bb5f51f39ba6ea289cdaef7e4dbb185d73e453dc56928be6e1939a48fadda33d9f9eb0752583adf7f80707072cd402a0
+EBUILD mdit-py-plugins-0.3.1.ebuild 739 BLAKE2B 86c6d0795b91acd45f22e24b3be11704d0bcd2aef6c98acfccc30a59ec0ae26feae37267a39927b2d2f5724d060880918896247a35028e4399ffe10f6d46b01e SHA512 178c9a5a9ef54d1c62e64120cb8b250391764ee0aa06920fcfce57beef96a851212e5bf4c9a4d76cb08937d330e21d9b2b212d46353d704c5b149f4a744f4901
MISC metadata.xml 414 BLAKE2B b7b6cfc3dff5ca097543d0541b066c466669ea3d9193e10530e97f6992053bedb67badf78023b14893d779a1580eb3bb385d51affc5a0927d76f89ddeed1be24 SHA512 564918fba45aa79a7a05d532691fe15aaa61a0e16e6004d57875720a26fc13548d37793fbab83479d0fc8c70764b3f919430a9bd698c03c85bf9103b56355166
diff --git a/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.1.ebuild b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.1.ebuild
new file mode 100644
index 000000000000..049b7b757192
--- /dev/null
+++ b/dev-python/mdit-py-plugins/mdit-py-plugins-0.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of plugins for markdown-it-py"
+HOMEPAGE="
+ https://pypi.org/project/mdit-py-plugins/
+ https://github.com/executablebooks/mdit-py-plugins/
+"
+SRC_URI="
+ https://github.com/executablebooks/mdit-py-plugins/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/markdown-it-py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest