summaryrefslogtreecommitdiff
path: root/dev-python/mccabe/mccabe-0.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/mccabe/mccabe-0.6.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/mccabe/mccabe-0.6.1.ebuild')
-rw-r--r--dev-python/mccabe/mccabe-0.6.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/mccabe/mccabe-0.6.1.ebuild b/dev-python/mccabe/mccabe-0.6.1.ebuild
new file mode 100644
index 000000000000..0830488a6c01
--- /dev/null
+++ b/dev-python/mccabe/mccabe-0.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="flake8 plugin: McCabe complexity checker"
+HOMEPAGE="https://github.com/PyCQA/mccabe"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e '/pytest-runner/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test -v || die "Testing failed with ${EPYTHON}"
+}