summaryrefslogtreecommitdiff
path: root/dev-python/mccabe/mccabe-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/mccabe/mccabe-0.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/mccabe/mccabe-0.2.1.ebuild')
-rw-r--r--dev-python/mccabe/mccabe-0.2.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/mccabe/mccabe-0.2.1.ebuild b/dev-python/mccabe/mccabe-0.2.1.ebuild
new file mode 100644
index 000000000000..113112563276
--- /dev/null
+++ b/dev-python/mccabe/mccabe-0.2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for flake8"
+HOMEPAGE="https://github.com/flintwork/mccabe"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 sparc x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pep8-1.4.3[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"