summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-19 23:08:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-19 23:08:59 +0000
commita29a0019eaf0bf87941bdc1d9cd53937685852ee (patch)
tree64c0a3ecbbede7a93bb6625c84b70668941be13a /dev-python/matplotlib
parent5a31d854eec302fd1efb1466af757e520ae4e1dc (diff)
gentoo auto-resync : 19:11:2023 - 23:08:59
Diffstat (limited to 'dev-python/matplotlib')
-rw-r--r--dev-python/matplotlib/Manifest2
-rw-r--r--dev-python/matplotlib/matplotlib-3.8.2.ebuild33
2 files changed, 30 insertions, 5 deletions
diff --git a/dev-python/matplotlib/Manifest b/dev-python/matplotlib/Manifest
index 1fa544d344e2..097680eeaabb 100644
--- a/dev-python/matplotlib/Manifest
+++ b/dev-python/matplotlib/Manifest
@@ -16,5 +16,5 @@ EBUILD matplotlib-3.7.2.ebuild 10289 BLAKE2B f39422d5796061fe3677957ebb0b2af9241
EBUILD matplotlib-3.7.3.ebuild 10008 BLAKE2B ca25579dc5c3f41a890c38e2889fbbbd99e51d5defabe926a172aec975415563225b84499fad053cc41f737da6d66506e1185e102259df5700985fd18420a04c SHA512 0da8c030af4744a84709f7baa7fd52052eb36731621cf20251620b2d29a9897c36ad136a2523ae03a6a1db7a81dab16f754d1120a9d4d3db3b8227d0caf54f4a
EBUILD matplotlib-3.8.0.ebuild 9996 BLAKE2B 5c98a40ceaae5787a0d76c653ff7e3c536ced712f816b9d8bbda24b2fd7c3b33760ce238313cb75966ac967a992e5682088774cbd962fa7c3205e795c977d96f SHA512 14285067ded8e0948ce382ae68202ec81cfbf749c5ad1e5503572e17c626d089e17dc36e50d021a95357e3874085642ee46d6514f6a8b31352e8491bd29cfd41
EBUILD matplotlib-3.8.1.ebuild 9998 BLAKE2B 40aab75a1ec2596e72a28785d4445ff43eee84259afdbbbbdbdbf534b90954f158936598e73bca89e92a8fefb7965e4a97547f0316fb726ac7a2eda42da2a5f0 SHA512 36508b6e597244a3085bbeb429dbeebf5608f04ec81109e2d0b38fb6391611e9b8a2b77e0a9e3da62cfd5dfcbf03a602025b0128c8be550e143c22b35aacf75a
-EBUILD matplotlib-3.8.2.ebuild 9989 BLAKE2B c9875eb8e7fb9554d13b3c5b30809fed2fc1a17d0861ad6c84de8a8a35945b4d54923b62d11b3afc2bb4f45fe50e1ace818ba0952b0063f654eb74c737fef6f1 SHA512 665e342183872c0a8bf577c9636866c37c831139d92a07e95bc5e4f33ef5cb631f716a6a15b5e82b874dc137763bbf348aacb57edd5a7033072ebf57a5fb2d3a
+EBUILD matplotlib-3.8.2.ebuild 10991 BLAKE2B 5f43d0157aceb767cc3190895e05c5fa57c5de2baf205e22bc3f463b5dd229ba02dc74d2d6d7755dbf6174478208a90f2e6ccad7430585b976d41f965979d713 SHA512 548bf41734db6691312aae9ab802d5b8870fcf61a9ae8b3a93055f4f1d34233d850ca438effb2675a30ff8b68d9f9c658b4f06df3e9546ea29180070a70cec60
MISC metadata.xml 1074 BLAKE2B 1d7dce116e09939378872c2eaf5153948b7e934626110eb4899d0dfc2781429522328f1c4efd2c40f829da64e19bed8f9fbd1b8907a6e74a5fd54587c1d29e5b SHA512 e344bfc813e09c24a8edfa9c062eb2a6c44535559370f508a27a2de20c6ab92aeb48bc8daf9c357178e513eb2474a33782e4098c0f3bcbb84b11f7388ef1a704
diff --git a/dev-python/matplotlib/matplotlib-3.8.2.ebuild b/dev-python/matplotlib/matplotlib-3.8.2.ebuild
index da349d6f5511..ce8672ca0961 100644
--- a/dev-python/matplotlib/matplotlib-3.8.2.ebuild
+++ b/dev-python/matplotlib/matplotlib-3.8.2.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_REQ_USE='tk?,threads(+)'
inherit distutils-r1 flag-o-matic prefix pypi toolchain-funcs virtualx
@@ -74,7 +74,9 @@ RDEPEND="
dev-texlive/texlive-xetex
)
qt5? (
- dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ ' 'python3*')
)
webagg? (
>=dev-python/tornado-6.0.4[${PYTHON_USEDEP}]
@@ -241,13 +243,36 @@ python_test() {
tests/test_testing.py::test_warn_to_fail
# TODO?
tests/test_backend_qt.py::test_fig_sigint_override
- # unhappy about xdist
- tests/test_widgets.py::test_span_selector_animated_artists_callback
# leak tests are fragile
tests/test_backends_interactive.py::test_figure_leak_20490
)
case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # TypeError is raised when exception is raised in a starred
+ # expression referencing a generator that uses "yield from"
+ # and raises -- non-critical, since some exception is raised
+ # after all
+ # https://foss.heptapod.net/pypy/pypy/-/issues/4032
+ tests/test_axes.py::test_bad_plot_args
+ tests/test_axes.py::test_plot_errors
+ tests/test_axes.py::test_plot_format_errors
+ # TODO: warning isn't passed through
+ tests/test_image.py::test_large_image
+ # TODO
+ tests/test_legend.py::test_plot_multiple_label_incorrect_length_exception
+ tests/test_pickle.py::test_complete
+ tests/test_pickle.py::test_no_pyplot
+ tests/test_pickle.py::test_pickle_load_from_subprocess
+ tests/test_pickle.py::test_simple
+ tests/test_texmanager.py::test_openin_any_paranoid
+ tests/test_widgets.py::test_check_buttons
+ tests/test_widgets.py::test_check_buttons_lines
+ tests/test_widgets.py::test_check_radio_buttons_image
+ tests/test_widgets.py::test_radio_buttons
+ )
+ ;;
python3.11)
EPYTEST_DESELECT+=(
# https://github.com/matplotlib/matplotlib/issues/23384