summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib2tikz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/matplotlib2tikz
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/matplotlib2tikz')
-rw-r--r--dev-python/matplotlib2tikz/Manifest3
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.17.ebuild38
-rw-r--r--dev-python/matplotlib2tikz/metadata.xml21
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
new file mode 100644
index 000000000000..28dd92a0d487
--- /dev/null
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -0,0 +1,3 @@
+DIST matplotlib2tikz-0.6.17.tar.gz 526409 BLAKE2B 704ede0539aeb9668b4c1534b6dd13bb2a5bc18e7861bfdbe2e9002cc5a8b8c4639ac77384e1249c52ef33e04986b85f27dc5219e9c9c7c8b7b03cb5a7bf586c SHA512 9a8f34a69147271bb252a4e04bc5ce27c39fc976c29d1530df109287bbfd163f37a3b5f3d6a03def962e06c2a69e7d256028b12372847fbe14459cc664eca199
+EBUILD matplotlib2tikz-0.6.17.ebuild 955 BLAKE2B 5dc841baa9fc2d386035961f4a042987e9d43c0753d0c4132c7ccf4c6775953e4f1a7963f6c587616ed7d86b30002c74b8b1b8873cd17b2a53c67a66eb10842a SHA512 655df388b916d6264ed977e4e18a7de5aa2c9fd72023a12e9ff94c01d2fdd44a4236a2ad2a854b5fb843b2e31f32f0580334c293dbf55cc99b81bdfded058299
+MISC metadata.xml 1108 BLAKE2B e2f8648c239f0f117db6f046e0a8fbb006ad25530e791987f974fed0ea105d626bbb867ddcbfba05b1fe041be751c7737fefe241ea31cb6acce89f9d0fc0c115 SHA512 ffd5556daf5c3903437775b6da6bda2623fe8a9d8d6d8a8ce2f3537c3c50bc57353fbb0151a40c1a7ed113fc0732b64b231a38b69f10a785f4e089d94c1507e1
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.17.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.17.ebuild
new file mode 100644
index 000000000000..bc9212c7a05a
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.17.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="https://github.com/nschloe/matplotlib2tikz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/ImageHash[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-tex/pgf
+ )"
+
+# we have not succeeded in getting the tests to work yet ;-)
+RESTRICT="test"
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx py.test -v || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/matplotlib2tikz/metadata.xml b/dev-python/matplotlib2tikz/metadata.xml
new file mode 100644
index 000000000000..a4fca97ba72e
--- /dev/null
+++ b/dev-python/matplotlib2tikz/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <longdescription>matplotlib2tikz is a Python tool for converting matplotlib figures into PGFPlots (TikZ) figures like for native inclusion into LaTeX documents. The output of matplotlib2tikz is in PGFPlots, a LaTeX library that sits on top of TikZ and describes graphs in terms of axes, data etc. Consequently, the output of matplotlib2tikz retains more information, can be more easily understood, and is more easily editable than raw TikZ output.</longdescription>
+ <upstream>
+ <remote-id type="github">nschloe/matplotlib2tikz</remote-id>
+ <remote-id type="pypi">matplotlib2tikz</remote-id>
+ </upstream>
+</pkgmetadata>