summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib-inline/matplotlib-inline-0.1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-18 20:35:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-18 20:35:08 +0100
commitf252a808abf092f718fbdfabb1c9b3ce51e62551 (patch)
treefd4d5d0c8c04a22190b7198efc5be56abf44a9f2 /dev-python/matplotlib-inline/matplotlib-inline-0.1.6.ebuild
parent3fb6e94893672e0dfbae682e6a3418e3f1260bf2 (diff)
gentoo auto-resync : 18:08:2022 - 20:35:07
Diffstat (limited to 'dev-python/matplotlib-inline/matplotlib-inline-0.1.6.ebuild')
-rw-r--r--dev-python/matplotlib-inline/matplotlib-inline-0.1.6.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/matplotlib-inline/matplotlib-inline-0.1.6.ebuild b/dev-python/matplotlib-inline/matplotlib-inline-0.1.6.ebuild
new file mode 100644
index 000000000000..90cd627e843a
--- /dev/null
+++ b/dev-python/matplotlib-inline/matplotlib-inline-0.1.6.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Inline Matplotlib backend for Jupyter"
+HOMEPAGE="https://github.com/ipython/matplotlib-inline/"
+SRC_URI="
+ https://github.com/ipython/matplotlib-inline/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"