summaryrefslogtreecommitdiff
path: root/dev-python/matplotlib-inline/matplotlib-inline-0.1.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-31 03:47:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-31 03:47:04 +0000
commita4d738a9d1fddef251ba88e258acdb50c243fa63 (patch)
tree1687346e6907f4670ab4015ff2e717c50d574f9c /dev-python/matplotlib-inline/matplotlib-inline-0.1.6-r1.ebuild
parent77922838ba6e7b5f546528626d41f2e7f3fc2c08 (diff)
gentoo auto-resync : 31:10:2023 - 03:47:04
Diffstat (limited to 'dev-python/matplotlib-inline/matplotlib-inline-0.1.6-r1.ebuild')
-rw-r--r--dev-python/matplotlib-inline/matplotlib-inline-0.1.6-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/matplotlib-inline/matplotlib-inline-0.1.6-r1.ebuild b/dev-python/matplotlib-inline/matplotlib-inline-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..0803c515b454
--- /dev/null
+++ b/dev-python/matplotlib-inline/matplotlib-inline-0.1.6-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Inline Matplotlib backend for Jupyter"
+HOMEPAGE="https://github.com/ipython/matplotlib-inline/"
+SRC_URI="
+ https://github.com/ipython/matplotlib-inline/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+# Although in theory we could depend on matplotlib, upstream does not.
+# This is because the sole purpose of the package is to be loaded by
+# ipython (also not a dependency!) as a response to interactive use of
+# the "%matplotlib" magic.
+#
+# In order to be seamless and straightforward, this backend is always
+# installed and just requires users using matplotlib, to install
+# matplotlib before importing and using it.
+RDEPEND="
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"