summaryrefslogtreecommitdiff
path: root/dev-python/markdown-it-py/markdown-it-py-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/markdown-it-py/markdown-it-py-2.1.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/markdown-it-py/markdown-it-py-2.1.0.ebuild')
-rw-r--r--dev-python/markdown-it-py/markdown-it-py-2.1.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/markdown-it-py/markdown-it-py-2.1.0.ebuild b/dev-python/markdown-it-py/markdown-it-py-2.1.0.ebuild
new file mode 100644
index 000000000000..aa68ea704662
--- /dev/null
+++ b/dev-python/markdown-it-py/markdown-it-py-2.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=flit
+inherit distutils-r1
+
+DESCRIPTION="Python port of markdown-it, Markdown parser"
+HOMEPAGE="https://pypi.org/project/markdown-it-py/
+ https://github.com/executablebooks/markdown-it-py"
+SRC_URI="
+ https://github.com/executablebooks/markdown-it-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/attrs-22[${PYTHON_USEDEP}]
+ dev-python/mdurl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Unimportant tests needing a new dep linkify
+ tests/test_linkify.py::test_token_levels
+ tests/test_port/test_fixtures.py::test_linkify
+)
+
+EPYTEST_IGNORE=(
+ # No need to benchmark
+ benchmarking/
+)