summaryrefslogtreecommitdiff
path: root/dev-python/markdown-exec/markdown-exec-1.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-16 12:04:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-16 12:04:26 +0100
commitb92911550490e2da121ec4b02d3cf60a2d31a17d (patch)
treedc29e698da3b00d42ead3796b35416159e83d57a /dev-python/markdown-exec/markdown-exec-1.8.1.ebuild
parent7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (diff)
gentoo auto-resync : 16:04:2024 - 12:04:26
Diffstat (limited to 'dev-python/markdown-exec/markdown-exec-1.8.1.ebuild')
-rw-r--r--dev-python/markdown-exec/markdown-exec-1.8.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/markdown-exec/markdown-exec-1.8.1.ebuild b/dev-python/markdown-exec/markdown-exec-1.8.1.ebuild
new file mode 100644
index 000000000000..a80628fef998
--- /dev/null
+++ b/dev-python/markdown-exec/markdown-exec-1.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Utilities to execute code blocks in Markdown files"
+HOMEPAGE="
+ https://pawamoy.github.io/markdown-exec/
+ https://pypi.org/project/markdown-exec/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+IUSE="ansi"
+
+RDEPEND="
+ >=dev-python/pymdown-extensions-9[${PYTHON_USEDEP}]
+ ansi? (
+ dev-python/pygments-ansi-color[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest