summaryrefslogtreecommitdiff
path: root/dev-python/mapbox-vector-tile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
commit1551fe56fd6ba43a94509cffc61b6bf854b7ac9f (patch)
treebe99b6ceb874878a108d68c641b476a2df076517 /dev-python/mapbox-vector-tile
parent0e2a727aba684f1a44cc0402a3f77d242140681b (diff)
gentoo auto-resync : 01:06:2024 - 00:07:06
Diffstat (limited to 'dev-python/mapbox-vector-tile')
-rw-r--r--dev-python/mapbox-vector-tile/Manifest2
-rw-r--r--dev-python/mapbox-vector-tile/mapbox-vector-tile-2.1.0.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/mapbox-vector-tile/Manifest b/dev-python/mapbox-vector-tile/Manifest
index 7284b2d84cbd..9285db56d10e 100644
--- a/dev-python/mapbox-vector-tile/Manifest
+++ b/dev-python/mapbox-vector-tile/Manifest
@@ -1,3 +1,5 @@
DIST mapbox-vector-tile-2.0.1.gh.tar.gz 229202 BLAKE2B 9afa12583f1f2697c8fd3a7ad540851c2b3ea7bca26bf7945aa52ad9c2486f4b6ec0a0bc84e750e18ecb55a51558659284d52efedcb724ec5de98f965d78b954 SHA512 67648c27792557a5e011732c31f8a0a3e6efca8630086e55e6fdc433953b820ef6405031d10692999026c604f3977eb00bafa9a1a7015f02c3dca87ca91eadf6
+DIST mapbox-vector-tile-2.1.0.gh.tar.gz 229585 BLAKE2B d4ed6034b8cea35b3bfe0db8ed3f9f094021654045dce560e36d9d21398c8cd41975848dd44de13c1e9f0a4c37d94835e349c9df7283b994fde60ff66eceda9d SHA512 d2ab9f0aba5150a4e9e0e7c9b29a3754f25ac9a1368e5c2909d773e1dc2197dcab59c047f68cdcf217727e0422bd8670ade797db74b26b95ce04f24564938c1d
EBUILD mapbox-vector-tile-2.0.1.ebuild 890 BLAKE2B 2dd416330a56bdfeb75a7e08894b37f68f0f747965d6cb8bf27a3a38b2b969fd9b7b8b13ea391f72dcab459430482817842da0225f02ae373fc6fa80c8b2cb35 SHA512 7c5e1db3a9b8ddd2474048bba29c89e0167364ce0d4a5ebc1404162d2e682a2424d4b5670a031b2e9d57835294fddc33f48b417854858986376bc629c1b6fd9f
+EBUILD mapbox-vector-tile-2.1.0.ebuild 986 BLAKE2B ac86b73b8c4349ecf95453accda66ba30490416b80a9f2a8b29db5ba0a7eae5150ece7d7a710c753b155dd42f4930eb6b9465ce31749f9e10c68931b6d463a3c SHA512 c3a128a31c6124f2961e3925eed127cef7047824baee104a1f3111d526ad09a6484de054e0adbf277b3bd6dd12f946b318503d4ca15fbe0a925753b719b7934f
MISC metadata.xml 564 BLAKE2B 48abaac3aae8007371f0fbfbe58910d820857a2231161c4ba2732509f3b1143cc3ba34094222ed7b8d45202b7f79ca36b5a2f24eaf572fdd1f949caa4c972a0f SHA512 09debdc5a9d7e80b19e7f64bbb4b560482efe294761f5d15b582c144c02b385fd2dfeefe912428d692ce5da916528f099f651a5be9f181435524ad066bb76e88
diff --git a/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.1.0.ebuild b/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.1.0.ebuild
new file mode 100644
index 000000000000..17a2fcdba745
--- /dev/null
+++ b/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mapbox Vector Tile encoding and decoding."
+HOMEPAGE="
+ https://github.com/tilezen/mapbox-vector-tile/
+ https://pypi.org/project/mapbox-vector-tile/
+"
+SRC_URI="https://github.com/tilezen/mapbox-vector-tile/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ >=dev-python/pyclipper-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyproj-3.4.1[${PYTHON_USEDEP}]
+ >=dev-python/shapely-2.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # don't install into top-level
+ sed -Ei '/include = \[/,/\]/ { /(README|CHANGELOG)/d }' pyproject.toml || die
+ # relax the dep
+ sed -i -e '/protobuf/s:\^[0-9.]*:*:' pyproject.toml || die
+ distutils-r1_src_prepare
+}