summaryrefslogtreecommitdiff
path: root/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 08:10:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 08:10:15 +0000
commitfceeb864f5e0e6155b3f5ed010298e5b7b2f1278 (patch)
treeeae9568ab98ccfbd977dade72fecdd45c670fc9d /dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild
parent517343fddd94e620e94be97ae22eca4b57dc7625 (diff)
gentoo auto-resync : 18:02:2023 - 08:10:15
Diffstat (limited to 'dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild')
-rw-r--r--dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild b/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild
new file mode 100644
index 000000000000..09c1d2ed9048
--- /dev/null
+++ b/dev-python/mapbox-vector-tile/mapbox-vector-tile-2.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Mapbox Vector Tile encoding and decoding."
+HOMEPAGE="
+ https://github.com/tilezen/mapbox-vector-tile/
+ https://pypi.org/project/mapbox-vector-tile/
+"
+SRC_URI="https://github.com/tilezen/mapbox-vector-tile/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pyclipper[${PYTHON_USEDEP}]
+ dev-python/pyproj[${PYTHON_USEDEP}]
+ dev-python/shapely[${PYTHON_USEDEP}]
+"
+BDEPEND="test? ( ${RDEPEND} )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # Dont install into top-level
+ sed -Ei '/include = \[/,/\]/ { /(README|CHANGELOG)/d }' pyproject.toml || die
+ default
+}