summaryrefslogtreecommitdiff
path: root/dev-python/mando/mando-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/mando/mando-0.7.1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/mando/mando-0.7.1.ebuild')
-rw-r--r--dev-python/mando/mando-0.7.1.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/dev-python/mando/mando-0.7.1.ebuild b/dev-python/mando/mando-0.7.1.ebuild
index 79d654424d5b..c86ae3090eb8 100644
--- a/dev-python/mando/mando-0.7.1.ebuild
+++ b/dev-python/mando/mando-0.7.1.ebuild
@@ -4,19 +4,29 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
DESCRIPTION="Create Python CLI apps with little to no effort at all!"
-HOMEPAGE="https://mando.readthedocs.io/ https://github.com/rubik/mando/"
-SRC_URI="https://github.com/rubik/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://mando.readthedocs.io/
+ https://github.com/rubik/mando/
+ https://pypi.org/project/mando/
+"
+SRC_URI="
+ https://github.com/rubik/mando/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="examples"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
distutils_enable_sphinx docs
distutils_enable_tests pytest