summaryrefslogtreecommitdiff
path: root/dev-python/mako
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-08 10:38:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-08 10:38:04 +0100
commitc02f0a2cafa1964dc62d8ef9312083b606a9b7c5 (patch)
treed45fcdd0335c79bdb4ce02ec5b5e6c681939881e /dev-python/mako
parent8bba0fff0bc9709d45aeb68336998e11d118ab05 (diff)
gentoo auto-resync : 08:09:2022 - 10:38:04
Diffstat (limited to 'dev-python/mako')
-rw-r--r--dev-python/mako/Manifest2
-rw-r--r--dev-python/mako/mako-1.2.1.ebuild58
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/mako/Manifest b/dev-python/mako/Manifest
index cc6723fd386d..8e861b6dd1bf 100644
--- a/dev-python/mako/Manifest
+++ b/dev-python/mako/Manifest
@@ -1,5 +1,3 @@
-DIST Mako-1.2.1.tar.gz 489560 BLAKE2B c8006d5f7a814a1466ad6643200693f014c4a23f284701a9bea6a27246c196c87e5c4bf8e12ae0525563ce60c93944a58b1fa45afc6caf3362aa1d761148910a SHA512 02393054c9e3857ee412f494b01d702b5f367165d2f57a5ff9df34ba1a042b60c7b6c059ce2c53bcb91e3a4a21179eca884ee051bf5f5f3522c05253088d38a5
DIST Mako-1.2.2.tar.gz 490741 BLAKE2B 88408c10c6cae891969d67b204ade6bead6ff8f8bc4521d0a48c049b97594deb286acbddf1135caae77813d8ea075c3825ff5c738b6dc3406b12fe2048099bdd SHA512 4a9303b18710ad8111f4a83e963289df490cf1d01bf3b262e89fb2e9bb98a96fe2c83f8900597d836411d136b6ccb686f67b6e1554c4fe4868e68af1c864bcfe
-EBUILD mako-1.2.1.ebuild 1356 BLAKE2B 4bd5b04fe7f801097f25592c45d6b6af67cda6c85fdbe766764fe2df5232af603f0949ca81a0edbef769186db9fa81c57f0dc3b92939a88df3d0b254dd4044f7 SHA512 65e911911bf6a94f0d132fcc4dddf49cc5e9a3cf1883e341d8da1d5b5894170f51a606ce7b98c1bec36cbede1d4d58227279b1ab6e04646af0722a9574abc247
EBUILD mako-1.2.2.ebuild 1079 BLAKE2B 5bdab1d2d11422fbbb8a6a915f089c244c1bad9ec99c5b076b8cdf994441aa7eb1dc154b4ffc7765176426d6befbb93ba21232f2295d4bc5960de7073852a8fc SHA512 13d1644d606f0bb5406d5e2939c61556a7bc6d322d3daa1e9a25a85245782d1ef7f6286f9f071d4736131c3a44a20be8c8056727b8ef01830a0d6a3f1b3761e3
MISC metadata.xml 450 BLAKE2B 271e9801e0361eb9cf222fa9aca34f641e6118e17707469a87c1b41a6de34c67ec6a19576a86cc3c7ba1f671f8a28f9df8e994b3f232fe224eda85f4b8cf8b8b SHA512 d168ca10d7759129088a0d10ad73e4d0973ccaed1e649828077158aee55a8640db2446c9d874ef0da4fba5b27a6a0eacdc9d9ff4ec04a19cd1b9699542b5b0c1
diff --git a/dev-python/mako/mako-1.2.1.ebuild b/dev-python/mako/mako-1.2.1.ebuild
deleted file mode 100644
index 61bedd65c827..000000000000
--- a/dev-python/mako/mako-1.2.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=${P^}
-DESCRIPTION="A Python templating language"
-HOMEPAGE="
- https://www.makotemplates.org/
- https://github.com/sqlalchemy/mako/
- https://pypi.org/project/Mako/
-"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="doc"
-
-RDEPEND="
- >=dev-python/markupsafe-0.9.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/Babel[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # change in pygments
- test/test_exceptions.py::ExceptionsTest::test_format_exceptions_pygments
- )
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- test/test_exceptions.py::ExceptionsTest::test_alternating_file_names
- )
- local EPYTEST_IGNORE=(
- # lingua is not packaged in Gentoo and the skip is currently broken
- # https://github.com/sqlalchemy/mako/pull/357
- test/ext/test_linguaplugin.py
- )
- epytest
-}
-
-python_install_all() {
- rm -r doc/build || die
-
- use doc && local HTML_DOCS=( doc/. )
- distutils-r1_python_install_all
-}