summaryrefslogtreecommitdiff
path: root/dev-python/mako
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/mako
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/mako')
-rw-r--r--dev-python/mako/Manifest2
-rw-r--r--dev-python/mako/mako-1.2.0.ebuild23
2 files changed, 21 insertions, 4 deletions
diff --git a/dev-python/mako/Manifest b/dev-python/mako/Manifest
index 661e68fe6367..656b606249ac 100644
--- a/dev-python/mako/Manifest
+++ b/dev-python/mako/Manifest
@@ -1,3 +1,3 @@
DIST Mako-1.2.0.tar.gz 488603 BLAKE2B 30ef597e2dd500d52d02118e0ec8a40cfeeff00604eb9fec887df4aff794aed7d6a1d78b2defb6f985947f9429d912a083b9941ee30b1e53ef32890d19e94158 SHA512 ad608016d7785a735a28ea18f697be4882da747e3da32e4a7c7be4bf846d37e4d3374d78e62ef85607ae9f3f73ee35dc78b473347e4110c059a504be2c497c6e
-EBUILD mako-1.2.0.ebuild 1154 BLAKE2B ab79ed2aff34992ab303ddc993a016c35e44758a62777a270fee9d31742ea4b14cc7d946fe6d2b48911a3349a47b26be9a9ce25793b9ae0fa0ae6621f99e7541 SHA512 a6a4a740b094d552a5aca57ce45459ac90989aef9ae035ded0a5f7584623c218f86ef0244648148a3e398ba1ce05493c8289b8c7ea682985ba395c96a50bf87a
+EBUILD mako-1.2.0.ebuild 1593 BLAKE2B e1e87bc2dd0ca3e55f799123a9a6543839ec76a0851ee465573cc5bd2b4c313f685c996b1e27852f13379c84a0c15d33a27cc974a26b0074a7d25c844288d88c SHA512 4a6358eb6f6937b8ae135dae83efd5d7f33a7f768c009886d8ae2aae014a7b1893e79bee38da7327647fa2c415e86377185e86cbd1bed2bc56546625efa682c9
MISC metadata.xml 450 BLAKE2B 271e9801e0361eb9cf222fa9aca34f641e6118e17707469a87c1b41a6de34c67ec6a19576a86cc3c7ba1f671f8a28f9df8e994b3f232fe224eda85f4b8cf8b8b SHA512 d168ca10d7759129088a0d10ad73e4d0973ccaed1e649828077158aee55a8640db2446c9d874ef0da4fba5b27a6a0eacdc9d9ff4ec04a19cd1b9699542b5b0c1
diff --git a/dev-python/mako/mako-1.2.0.ebuild b/dev-python/mako/mako-1.2.0.ebuild
index f42ab071d63c..16fca49e82f0 100644
--- a/dev-python/mako/mako-1.2.0.ebuild
+++ b/dev-python/mako/mako-1.2.0.ebuild
@@ -4,13 +4,17 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
MY_P=${P^}
DESCRIPTION="A Python templating language"
-HOMEPAGE="https://www.makotemplates.org/ https://pypi.org/project/Mako/"
+HOMEPAGE="
+ https://www.makotemplates.org/
+ https://github.com/sqlalchemy/mako/
+ https://pypi.org/project/Mako/
+"
SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
@@ -22,14 +26,27 @@ IUSE="doc"
RDEPEND="
>=dev-python/markupsafe-0.9.2[${PYTHON_USEDEP}]
"
+BDEPEND="
+ test? (
+ dev-python/Babel[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
python_test() {
- local EPYTEST_DESELECT=()
+ local EPYTEST_DESELECT=(
+ # change in pygments
+ test/test_exceptions.py::ExceptionsTest::test_format_exceptions_pygments
+ )
[[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
test/test_exceptions.py::ExceptionsTest::test_alternating_file_names
)
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # py3.11 changed tracebacks
+ test/test_exceptions.py::ExceptionsTest::test_tback_no_trace_from_py_file
+ test/test_exceptions.py::ExceptionsTest::test_tback_trace_from_py_file
+ )
local EPYTEST_IGNORE=(
# lingua is not packaged in Gentoo and the skip is currently broken
# https://github.com/sqlalchemy/mako/pull/357