summaryrefslogtreecommitdiff
path: root/dev-python/makefun/makefun-1.15.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-24 09:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-24 09:47:15 +0000
commit4003c614d3c4b320c45ab1f4b817459d4709443b (patch)
treefcc0c42e92c56abe0ea39b717b2c3b019c335e41 /dev-python/makefun/makefun-1.15.1.ebuild
parent58177544118b9a8393d7501ee5e0e35cd32f2ad4 (diff)
gentoo auto-resync : 24:02:2023 - 09:47:15
Diffstat (limited to 'dev-python/makefun/makefun-1.15.1.ebuild')
-rw-r--r--dev-python/makefun/makefun-1.15.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/makefun/makefun-1.15.1.ebuild b/dev-python/makefun/makefun-1.15.1.ebuild
new file mode 100644
index 000000000000..a509714c5540
--- /dev/null
+++ b/dev-python/makefun/makefun-1.15.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small library to dynamically create Python functions"
+HOMEPAGE="
+ https://pypi.org/project/makefun/
+ https://github.com/smarie/python-makefun/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/pytest-runner/d' -i setup.cfg || die
+ distutils-r1_src_prepare
+}