summaryrefslogtreecommitdiff
path: root/dev-python/lz4/lz4-0.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/lz4/lz4-0.8.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/lz4/lz4-0.8.2.ebuild')
-rw-r--r--dev-python/lz4/lz4-0.8.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/lz4/lz4-0.8.2.ebuild b/dev-python/lz4/lz4-0.8.2.ebuild
new file mode 100644
index 000000000000..b75564adfb8e
--- /dev/null
+++ b/dev-python/lz4/lz4-0.8.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.python.org/pypi/lz4 https://github.com/steeve/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ sed \
+ -e '/nose/s:setup_requires:test_requires:g' \
+ -i setup.py || die
+ mkdir "${S}"/tests
+ cp "${FILESDIR}"/test.py "${S}"/tests
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test || dies "Tests failed with ${EPYTHON}"
+}