summaryrefslogtreecommitdiff
path: root/dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-26 23:59:37 +0100
commit3e42d1577189af123b773dc0f11e5419035308c8 (patch)
tree95d77507c924544b12363e6da6aa741c444f3e8a /dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild
parent6243676c91946098c06d42bc87b5eb99aac40bf0 (diff)
gentoo auto-resync : 26:04:2024 - 23:59:36
Diffstat (limited to 'dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild')
-rw-r--r--dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild b/dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild
new file mode 100644
index 000000000000..be9038fb8598
--- /dev/null
+++ b/dev-python/lxml-html-clean/lxml-html-clean-0.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Separate project for HTML cleaning functionalities copied from lxml.html.clean"
+HOMEPAGE="
+ https://pypi.org/project/lxml-html-clean/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/lxml-5.2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest