summaryrefslogtreecommitdiff
path: root/dev-python/loky/loky-3.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-17 22:03:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-17 22:03:16 +0100
commit94dd707d272879a8dfdd31d71113b1b7bba98366 (patch)
tree615875fa702a02f83e99f52ddb3a3fb0375a5674 /dev-python/loky/loky-3.4.1.ebuild
parent29ef84a753ab20dbbb228238713a3c7443c6520e (diff)
gentoo auto-resync : 17:10:2023 - 22:03:16
Diffstat (limited to 'dev-python/loky/loky-3.4.1.ebuild')
-rw-r--r--dev-python/loky/loky-3.4.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/loky/loky-3.4.1.ebuild b/dev-python/loky/loky-3.4.1.ebuild
index 8503470eaf5a..456f7062da8e 100644
--- a/dev-python/loky/loky-3.4.1.ebuild
+++ b/dev-python/loky/loky-3.4.1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
-inherit distutils-r1
+inherit distutils-r1 multiprocessing
DESCRIPTION="Robust and reusable Executor for joblib"
HOMEPAGE="
@@ -30,6 +30,7 @@ BDEPEND="
test? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"
@@ -44,6 +45,8 @@ python_test() {
tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
)
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
# high memory test needs a lot of memory + is broken on 32-bit platforms
- epytest --skip-high-memory
+ epytest --skip-high-memory \
+ -p xdist -n "$(makeopts_jobs)" --dist=worksteal
}