summaryrefslogtreecommitdiff
path: root/dev-python/loky/loky-3.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-16 10:06:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-16 10:06:32 +0100
commit11263cb7c372230b9e5c0195c24692e299887573 (patch)
tree6da3f9cf32762190d60c9dc5f5665b6f6b112833 /dev-python/loky/loky-3.3.0.ebuild
parentd7665b9dae37c3b9a1c72157fdf49c101bd6495e (diff)
gentoo auto-resync : 16:05:2023 - 10:06:32
Diffstat (limited to 'dev-python/loky/loky-3.3.0.ebuild')
-rw-r--r--dev-python/loky/loky-3.3.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/loky/loky-3.3.0.ebuild b/dev-python/loky/loky-3.3.0.ebuild
deleted file mode 100644
index 1c2397693bbb..000000000000
--- a/dev-python/loky/loky-3.3.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2020-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Robust and reusable Executor for joblib"
-HOMEPAGE="https://github.com/joblib/loky"
-SRC_URI="
- https://github.com/joblib/loky/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/cloudpickle[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- EPYTEST_DESELECT=(
- # docker, seriously?
- tests/test_loky_module.py::test_cpu_count_cfs_limit
- # hangs, and even pytest-timeout does not help
- tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill
- tests/test_reusable_executor.py::TestResizeExecutor::test_reusable_executor_resize
- )
-
- # high memory test needs a lot of memory + is broken on 32-bit platforms
- epytest --skip-high-memory
-}