summaryrefslogtreecommitdiff
path: root/dev-python/loguru
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /dev-python/loguru
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'dev-python/loguru')
-rw-r--r--dev-python/loguru/Manifest3
-rw-r--r--dev-python/loguru/loguru-0.2.6_pre20190412.ebuild49
-rw-r--r--dev-python/loguru/metadata.xml16
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/loguru/Manifest b/dev-python/loguru/Manifest
new file mode 100644
index 000000000000..e68192881f89
--- /dev/null
+++ b/dev-python/loguru/Manifest
@@ -0,0 +1,3 @@
+DIST loguru-0.2.6_pre20190412.tar.gz 362315 BLAKE2B 8273fd42522396d4a17c405bebf01f8de272a56515e4a63766126494b4449333e7c25f5be5851bdbcf922d35affa9ee091ac7138482f9e2daf30f48093cee812 SHA512 49320c19f2bfdc55569290740b49889133003329dbf6cae2e993730a957d69e5200b41b75d255d2e19d937658778945ffe44350431661162eaa6141edfcfc499
+EBUILD loguru-0.2.6_pre20190412.ebuild 1125 BLAKE2B 442009acf68b49846ca90ffb5b5234e9e99e0fd6d1c25d11fbbe01c9b5b9bb34e5d968b4a9035846912c1313b165969d8e920e6b93298b20d868122c53892389 SHA512 fa0e737d2b3710e7dd1bca02d4e94d2136084a930a43955b6c8c462efd2993ad6bb0a6a69ec9e0e10884a76d3d81fb6692df04bb07ffe792068c3238d46ab94b
+MISC metadata.xml 683 BLAKE2B bd44db6c47f17a714eb8080d63d5002bbedf247787d568735f87f8aa01a13fc32d383f4eab2b92536a2f98f5b76b0ae01c407bf3c746b08c668ef562cf488ed0 SHA512 8a671ba69aa489f384c7074623f62c03905442b14b6b12bc9f306416a66390a334dcdadf84a5485936b47ff9992ac87e35ffbc8ae17d035b381f53f721b2369b
diff --git a/dev-python/loguru/loguru-0.2.6_pre20190412.ebuild b/dev-python/loguru/loguru-0.2.6_pre20190412.ebuild
new file mode 100644
index 000000000000..04098605437c
--- /dev/null
+++ b/dev-python/loguru/loguru-0.2.6_pre20190412.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+EGIT_COMMIT="6571879c37904e3a18567e694d70651c6886b860"
+
+DESCRIPTION="Python logging made (stupidly) simple"
+HOMEPAGE="https://github.com/Delgan/loguru"
+SRC_URI="https://github.com/Delgan/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+ >=dev-python/ansimarkup-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.4[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/isort-4.3.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.9.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ pytest -v || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/loguru/metadata.xml b/dev-python/loguru/metadata.xml
new file mode 100644
index 000000000000..b72d659dc843
--- /dev/null
+++ b/dev-python/loguru/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <longdescription lang="en">
+ This library is intended to make Python logging less painful by adding a bunch of useful functionalities that solve caveats of the standard loggers.
+ Using logs in your application should be an automatism, Loguru tries to make it both pleasant and powerful.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Delgan/loguru</remote-id>
+ <remote-id type="pypi">loguru</remote-id>
+ </upstream>
+</pkgmetadata>