summaryrefslogtreecommitdiff
path: root/dev-python/loguru/loguru-0.6.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 14:24:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 14:24:26 +0000
commit171d09fa1f429aa43835c618a2c21753ad5209a4 (patch)
tree7a9f3e0ed5e5a7dbabf98c971e8202b7ce50035b /dev-python/loguru/loguru-0.6.0-r1.ebuild
parent1826a30af36ae674cb71400eacaf0a0762df510f (diff)
gentoo auto-resync : 21:02:2023 - 14:24:25
Diffstat (limited to 'dev-python/loguru/loguru-0.6.0-r1.ebuild')
-rw-r--r--dev-python/loguru/loguru-0.6.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/loguru/loguru-0.6.0-r1.ebuild b/dev-python/loguru/loguru-0.6.0-r1.ebuild
new file mode 100644
index 000000000000..6c59eba2c805
--- /dev/null
+++ b/dev-python/loguru/loguru-0.6.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python logging made (stupidly) simple"
+HOMEPAGE="
+ https://github.com/Delgan/loguru/
+ https://pypi.org/project/loguru/
+"
+SRC_URI="
+ https://github.com/Delgan/loguru/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/colorama-0.3.4[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/0.6.0-typos.patch"
+)
+
+# filesystem buffering tests may fail
+# on tmpfs with 64k PAGESZ, but pass fine on ext4
+distutils_enable_tests pytest