summaryrefslogtreecommitdiff
path: root/dev-python/lmdb/lmdb-1.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-python/lmdb/lmdb-1.1.1-r1.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-python/lmdb/lmdb-1.1.1-r1.ebuild')
-rw-r--r--dev-python/lmdb/lmdb-1.1.1-r1.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/lmdb/lmdb-1.1.1-r1.ebuild b/dev-python/lmdb/lmdb-1.1.1-r1.ebuild
deleted file mode 100644
index 587621283a02..000000000000
--- a/dev-python/lmdb/lmdb-1.1.1-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for the Lightning Database"
-HOMEPAGE="https://github.com/jnwatson/py-lmdb/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="OPENLDAP"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND=">=dev-db/lmdb-0.9.28:="
-DEPEND="${RDEPEND}"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_compile() {
- LMDB_FORCE_SYSTEM=1 distutils-r1_python_compile
-}
-
-python_test() {
- pytest tests -vv || die "Tests fail with ${EPYTHON}"
-}
-
-python_install() {
- # This is required when the CFFI extension is used (for PyPy3)
- LMDB_FORCE_SYSTEM=1 distutils-r1_python_install
-}