summaryrefslogtreecommitdiff
path: root/dev-python/llvmlite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/llvmlite
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/llvmlite')
-rw-r--r--dev-python/llvmlite/Manifest2
-rw-r--r--dev-python/llvmlite/llvmlite-0.35.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/llvmlite/Manifest b/dev-python/llvmlite/Manifest
index e2081488e19a..28e27b8ddf01 100644
--- a/dev-python/llvmlite/Manifest
+++ b/dev-python/llvmlite/Manifest
@@ -1,3 +1,5 @@
DIST llvmlite-0.34.0.gh.tar.gz 210438 BLAKE2B 832ec28047a51b2874a0de5885445b9d77942a70f86620dfb0b25ff0b17395b6009d31d5e9f27ddf02c19ae97bd5b325fc49227fdc0499a9f5fa3bde44e6b564 SHA512 5540df4ebad835e294c00cc09ab1230a530566f563f751f890752f6e22f7b2a04aedcbb53dbbb8e323198d05c80bc9699b593d919eaf1af60fa6f94ff6f50bb1
+DIST llvmlite-0.35.0.gh.tar.gz 228089 BLAKE2B 5cee01244552cfc1c2ba979709170484ed253f52c5c47a4a254bf7d26c935ff0d2a858b7a7f4ec7719644495383128adab11a1287849cd426b7997da4a59efeb SHA512 345b6321277749a169cd87e152261ef499edbf18d18ef7085017c111f2892eac0241529cfae9c6eaaeb68cdb4d726965ed03b4d5a836501dcbdaa73d3c0796fd
EBUILD llvmlite-0.34.0.ebuild 1354 BLAKE2B 0479672c088a56c7f27bb2a7cd615448d456f5db3e042ce608ec1f12dc69b4fbcb95db79efc8783c9333d6e52672ba7abecfc3b68accc5bd15618003206fb660 SHA512 97248a6a08962e07dd5dce71bf52eb75c76630d634d9e423ed02b1bd6dc178b24bd38fc5f1436edb563a9475555218f39cb84bf086ec82457e5403c6714903b6
+EBUILD llvmlite-0.35.0.ebuild 1358 BLAKE2B 30c83734202847c4e5da441445bac1c17928d011c87eee2d966d42b924d853529d2cc94f260a955d4a4570944f9e437c785ec1e8c8832c656567fdeb90d7275d SHA512 8775329a09c3ac903be72b4d3e329ab2971eda6596687231a096e0942daff6c78d15d66a68b8334a5fe5f647ef67d6ef4e7aec69efba466f61a53a4f8bf63170
MISC metadata.xml 792 BLAKE2B 8247c0ac546df47bc70b8e525d776dd391fa553d75d7bb0507986ac2f7efe1d023db7259f8938c13b383ef719a10acb3e1357bca4dc398a42b68ba756c0c351a SHA512 8dab7bc4b6d33f9a3c458dde08e07fe22680238185e8f144ada7ce7374ecb3fbd38149f67d2a11cba7a816384c556edf618e45ec331e6054b97aee60c529a35a
diff --git a/dev-python/llvmlite/llvmlite-0.35.0.ebuild b/dev-python/llvmlite/llvmlite-0.35.0.ebuild
new file mode 100644
index 000000000000..3fa3c11d9cb7
--- /dev/null
+++ b/dev-python/llvmlite/llvmlite-0.35.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 llvm
+
+DESCRIPTION="Python wrapper around the llvm C++ library"
+HOMEPAGE="https://llvmlite.pydata.org/"
+SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
+S=${WORKDIR}/${P/_/}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+LLVM_MAX_SLOT=10
+
+RDEPEND="
+ sys-devel/llvm:${LLVM_MAX_SLOT}
+ sys-libs/zlib:0=
+"
+DEPEND="${RDEPEND}"
+
+python_configure_all() {
+ # upstream's build system is just horrible, and they ignored the PR
+ # fixing it, so let's build the shared lib properly using implicit
+ # make rules
+
+ export LDLIBS=$(llvm-config --libs all)
+ export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
+ export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
+
+ local files=( ffi/*.cpp )
+ emake -f - <<EOF
+ffi/libllvmlite.so: ${files[*]/.cpp/.o}
+ \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
+EOF
+
+ export LLVMLITE_SKIP_LLVM_VERSION_CHECK=1
+}
+
+python_test() {
+ "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}