summaryrefslogtreecommitdiff
path: root/dev-python/llvmlite/llvmlite-0.36.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /dev-python/llvmlite/llvmlite-0.36.0.ebuild
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'dev-python/llvmlite/llvmlite-0.36.0.ebuild')
-rw-r--r--dev-python/llvmlite/llvmlite-0.36.0.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/llvmlite/llvmlite-0.36.0.ebuild b/dev-python/llvmlite/llvmlite-0.36.0.ebuild
deleted file mode 100644
index e7d1d1dbbe84..000000000000
--- a/dev-python/llvmlite/llvmlite-0.36.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1 llvm
-
-DESCRIPTION="Python wrapper around the llvm C++ library"
-HOMEPAGE="https://llvmlite.pydata.org/"
-SRC_URI="https://github.com/numba/llvmlite/archive/v${PV/_/}.tar.gz -> ${P/_/}.gh.tar.gz"
-S=${WORKDIR}/${P/_/}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-LLVM_MAX_SLOT=10
-
-RDEPEND="
- sys-devel/llvm:${LLVM_MAX_SLOT}
- sys-libs/zlib:0=
-"
-DEPEND="${RDEPEND}"
-
-python_configure_all() {
- # upstream's build system is just horrible, and they ignored the PR
- # fixing it, so let's build the shared lib properly using implicit
- # make rules
-
- export LDLIBS=$(llvm-config --libs all)
- export CXXFLAGS="$(llvm-config --cxxflags) -fPIC ${CXXFLAGS}"
- export LDFLAGS="$(llvm-config --ldflags) ${LDFLAGS}"
-
- local files=( ffi/*.cpp )
- emake -f - <<EOF
-ffi/libllvmlite.so: ${files[*]/.cpp/.o}
- \$(CXX) -shared \$(CXXFLAGS) \$(LDFLAGS) -o \$@ \$^ \$(LDLIBS)
-EOF
-
- export LLVMLITE_SKIP_LLVM_VERSION_CHECK=1
-}
-
-python_test() {
- "${EPYTHON}" runtests.py -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}